<!DOCTYPE html><html lang="en-US"
xmlns:og="http://opengraphprotocol.org/schema/"
xmlns:fb="http://www.facebook.com/2008/fbml"><head>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-34813422-1"></script> <script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-34813422-1');</script> <meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://www.themovieblog.com/xmlrpc.php"><!-- <link media="all" href="https://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_0e7eba901522a96d50e5d71ce53a5768.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/l8k6wm5h/hk894.css" media="all"/><!-- <link media="screen" href="https://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_2baad7f35bbed7a951e82f6c7abca532.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/scgm7mv/dctvs.css" media="screen"/><title>&quot;Incubated&quot; (2021): Madness marinating in a Mack Truck | The Movie Blog</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="&quot;Incubated&quot; (2021): Madness marinating in a Mack Truck | The Movie Blog" /><meta property="og:description" content="Synopsis Sean is a Texas truck driver whose mental illness overwhelms him during the outset of the 2020 COVID-19 pandemic in the new based-on-actual-events domestic drama &#8220;Incubated&#8221;. Alarming, and ill-informed, radio newscasts propel Sean into uncontrollable hysteria, and his meds don&#8217;t appear to be furnishing their usual and dependable steadying ... [Read More]" /><meta property="og:url" content="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" /><meta property="og:site_name" content="The Movie Blog" /><meta property="article:publisher" content="https://www.facebook.com/TheMovieBlogOnline/" /><meta property="article:published_time" content="2021-08-26T02:42:19+00:00" /><meta property="article:modified_time" content="2021-08-26T03:08:19+00:00" /><meta property="og:image" content="https://www.themovieblog.com/wp-content/uploads/2021/08/incubated-2021.jpg" /><meta property="og:image:width" content="165" /><meta property="og:image:height" content="248" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@QwikFlickCritic" /><meta name="twitter:site" content="@tmb_tweets" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.themovieblog.com/#organization","name":"The Movie Blog","url":"https://www.themovieblog.com/","sameAs":["https://www.facebook.com/TheMovieBlogOnline/","https://www.youtube.com/channel/UC_TTz3vTPWqSgrqGdW2LLlQ","https://twitter.com/tmb_tweets"],"logo":{"@type":"ImageObject","@id":"https://www.themovieblog.com/#logo","inLanguage":"en-US","url":"https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_.png","width":512,"height":512,"caption":"The Movie Blog"},"image":{"@id":"https://www.themovieblog.com/#logo"}},{"@type":"WebSite","@id":"https://www.themovieblog.com/#website","url":"https://www.themovieblog.com/","name":"The Movie Blog","description":"The Official Home of Correct Movie Opinions","publisher":{"@id":"https://www.themovieblog.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.themovieblog.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#primaryimage","inLanguage":"en-US","url":"https://www.themovieblog.com/wp-content/uploads/2021/08/incubated-2021.jpg","width":165,"height":248},{"@type":"WebPage","@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#webpage","url":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/","name":"\"Incubated\" (2021): Madness marinating in a Mack Truck | The Movie Blog","isPartOf":{"@id":"https://www.themovieblog.com/#website"},"primaryImageOfPage":{"@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#primaryimage"},"datePublished":"2021-08-26T02:42:19+00:00","dateModified":"2021-08-26T03:08:19+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/"]}]},{"@type":"Article","@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#article","isPartOf":{"@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#webpage"},"author":{"@id":"https://www.themovieblog.com/#/schema/person/8ad98039cefd7e154ce29262afcf9e12"},"headline":"&#8220;Incubated&#8221; (2021): Madness marinating in a Mack Truck","datePublished":"2021-08-26T02:42:19+00:00","dateModified":"2021-08-26T03:08:19+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#webpage"},"publisher":{"@id":"https://www.themovieblog.com/#organization"},"image":{"@id":"https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#primaryimage"},"keywords":"Drama,Incubated,mental illness,new film","articleSection":"Reviews","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#respond"]}]},{"@type":["Person"],"@id":"https://www.themovieblog.com/#/schema/person/8ad98039cefd7e154ce29262afcf9e12","name":"John Smistad","image":{"@type":"ImageObject","@id":"https://www.themovieblog.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/12f078bd62e7bcaebc75aaae62fd5834?s=96&d=mm&r=pg","caption":"John Smistad"},"description":"I am a voracious writer of Movie Reviews. Check 'em out at my Blog, \"The Quick Flick Critic\", @: The Quick Flick Critic Thanks guys! John","sameAs":["https://www.linkedin.com/in/johnsmistad/","https://twitter.com/@QwikFlickCritic"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Feed" href="https://www.themovieblog.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Comments Feed" href="https://www.themovieblog.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; &#8220;Incubated&#8221; (2021): Madness marinating in a Mack Truck Comments Feed" href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.themovieblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.6"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='awaken-pro-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu%3Aregular%2Citalic%2C700%2C500|Roboto+Condensed%3Aregular%2Citalic%2C700|Source+Sans+Pro%3Aregular%2Citalic%2C700%26subset%3Dlatin%2Clatin' type='text/css' media='screen' /> <script src='//www.themovieblog.com/wp-content/cache/wpfc-minified/1e9bhqtc/dctvs.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://www.themovieblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> --> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/respond.min.js?ver=5.4.6'></script> <![endif]--> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/html5shiv.js?ver=5.4.6'></script> <![endif]--><link rel='https://api.w.org/' href='https://www.themovieblog.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.themovieblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.themovieblog.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.6" /><link rel='shortlink' href='https://www.themovieblog.com/?p=963244' /><link rel="alternate" type="application/json+oembed" href="https://www.themovieblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.themovieblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F&#038;format=xml" /><meta property="fb:app_id" content="213014669302515"/><meta property="fb:pages" content="336692746071 " /><meta property="og:locale" content="en_US" /><meta property="og:locale:alternate" content="en_US" /><meta property="fb:app_id" content="293076464454881" /><meta property="og:site_name" content="The Movie Blog" /><meta property="og:title" content="“Incubated” (2021): Madness marinating in a Mack Truck" /><meta property="og:url" content="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" /><meta property="og:description" content="Synopsis Sean is a Texas truck driver whose mental illness overwhelms him during the outset of the 2020 COVID-19 pandemic in the new based-on-actual-events domestic drama &amp;#8220;Incubated&amp;#8221;. Alarming, and ill-informed, radio newscasts propel Sean into uncontrollable hysteria, and his meds don&amp;#8217;t appear to be furnishing their usual and dependable steadying&lt;a class=&quot;moretag&quot; href=&quot;https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/&quot;&gt; ... [Read More]&lt;/a&gt;" /><meta property="og:type" content="Article" /><link rel="icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-180x180.png" /><meta name="msapplication-TileImage" content="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-270x270.png" /></head><body class="post-template-default single single-post postid-963244 single-format-standard group-blog "><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><div class="top-nav"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 "><nav id="top-navigation" class="top-navigation" role="navigation"><div class="menu-social-bot-container"><ul id="menu-social-bot" class="menu"><li id="menu-item-229448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229448"><a href="https://www.twitter.com/TMB_Tweets">Twitter</a></li><li id="menu-item-229449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229449"><a title="publisher" href="https://plus.google.com/109872712801302940080">Google +</a></li><li id="menu-item-229450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229450"><a href="https://www.facebook.com/pages/The-Movie-Blog-Fan-Page/336692746071">Facebook</a></li><li id="menu-item-229452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229452"><a href="https://www.themovieblog.com/feed">RSS</a></li><li id="menu-item-947974" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-947974"><a href="https://www.instagram.com/themovieblogonline">Instagram</a></li></ul></div></nav> <a href="#" class="navbutton" id="top-nav-button">Top Menu</a><div class="responsive-topnav"></div></div><div class="col-xs-12 col-sm-12 col-md-4"><div class="asocial-area"> <span class="asocial-icon facebook"><a href="https://www.facebook.com/TheMovieBlogOnline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Facebook" target="_blank"><i class="fa fa-facebook"></i></a></span> <span class="asocial-icon twitter"><a href="https://twitter.com/tmb_tweets?lang=en" data-toggle="tooltip" data-placement="bottom" title="Find us on Twitter" target="_blank"><i class="fa fa-twitter"></i></a></span> <span class="asocial-icon youtube"><a href="https://www.youtube.com/c/Themovieblog?sub_confirmation=1" data-toggle="tooltip" data-placement="bottom" title="Find us on Youtube" target="_blank"><i class="fa fa-youtube"></i></a></span> <span class="asocial-icon rss"><a href="https://www.themovieblog.com/feed" data-toggle="tooltip" data-placement="bottom" title="Find us on RSS" target="_blank"><i class="fa fa-rss"></i></a></span> <span class="asocial-icon instagram"><a href="https://www.instagram.com/themovieblogonline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Instagram" target="_blank"><i class="fa fa-instagram"></i></a></span></div></div></div></div></div><div class="site-branding"><div class="container"><div class="site-brand-container"><div class="site-title-text"><h1 class="site-title"><a href="https://www.themovieblog.com/" rel="home">The Movie Blog</a></h1><h2 class="site-description">The Official Home of Correct Movie Opinions</h2></div></div><div class="header-ad-area"><div id="secondary" class="widget-area" role="complementary"><aside id="text-12" class="widget widget_text"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-1282480773966371"
data-ad-slot="7135789799"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div></div></div></div><div class="container"><div class="awaken-navigation-container"><nav id="site-navigation" class="main-navigation cl-effect-10" role="navigation"><div class="menu-browse-container"><ul id="menu-browse" class="menu"><li id="menu-item-960452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-960452"><a href="https://teespring.com/stores/themovieblog">Shop</a></li><li id="menu-item-229439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229439"><a href="https://www.themovieblog.com/category/uncategorized/">News Chat</a></li><li id="menu-item-229440" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-229440"><a href="https://www.themovieblog.com/category/features/reviews/">Reviews</a></li><li id="menu-item-229443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229443"><a href="https://www.themovieblog.com/category/features/interviews/">Interviews</a></li><li id="menu-item-918311" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-918311"><a href="https://www.themovieblog.com/category/features/">Features</a></li><li id="menu-item-229441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229441"><a href="https://www.themovieblog.com/category/trailers/">Trailers</a></li><li id="menu-item-947973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-947973"><a href="https://www.themovieblog.com/category/features/contests/">Contests</a></li><li id="menu-item-931821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931821"><a href="https://www.themovieblog.com/contact/">Contact Us</a></li><li id="menu-item-931822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931822"><a href="https://www.themovieblog.com/about/">About</a></li></ul></div></nav> <a href="#" class="navbutton" id="main-nav-button">Main Menu</a><div class="responsive-mainnav"></div><div class="awaken-search-button-icon"></div><div class="awaken-search-box-container"><div class="awaken-search-box"><form action="https://www.themovieblog.com/" id="awaken-search-form" method="get"> <input type="text" value="" name="s" id="s" /> <input type="submit" value="Search" /></form></div></div></div></div></header><div id="content" class="site-content"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 awaken-content-float"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><article id="post-963244" class="post-963244 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-drama tag-incubated tag-mental-illness tag-new-film"><header class="single-entry-header"><h1 class="single-entry-title">&#8220;Incubated&#8221; (2021): Madness marinating in a Mack Truck</h1><div class="single-entry-meta"> <span class="posted-on"><a href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" rel="bookmark"><time class="entry-date published" datetime="2021-08-25T22:42:19-04:00">August 25, 2021</time><time class="updated" datetime="2021-08-25T23:08:19-04:00">August 25, 2021</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="https://www.themovieblog.com/author/john-smistad/">John Smistad</a></span></span> <span class="comments-link"><a href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="963244 https://www.themovieblog.com/?p=963244">Leave a comment</span></a></span></div></header><div class="article-featured-image"> <img width="165" height="248" src="https://www.themovieblog.com/wp-content/uploads/2021/08/incubated-2021.jpg" class="attachment-featured-slider size-featured-slider wp-post-image" alt="" /></div><div class="entry-content"><div class="fb-like" data-href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div><p><iframe title="Incubated Trailer #1 (Official Trailer)" width="747" height="420" src="https://www.youtube.com/embed/rRsAt89X_H0?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><h2>Synopsis</h2><p>Sean is a Texas truck driver whose mental illness overwhelms him during the outset of the 2020 COVID-19 pandemic in the new based-on-actual-events domestic drama &#8220;Incubated&#8221;. Alarming, and ill-informed, radio newscasts propel Sean into uncontrollable hysteria, and his meds don&#8217;t appear to be furnishing their usual and dependable steadying influence. Struggling to balance his sanity and keep his family safe and protected from the virus, inexplicable events begin to haunt him. Consumed with panic, Sean traps himself inside of his 18-wheeler, refusing to leave. His emotionally drained wife, Morgan, fights fiercely to piece her family back together as Sean turns to his therapist for strength to return home.</p><h2>The Good</h2><figure id="attachment_963249" aria-describedby="caption-attachment-963249" style="width: 291px" class="wp-caption alignleft"><img class="wp-image-963249 size-thumbnail" src="https://www.themovieblog.com/wp-content/uploads/2021/08/unnamed-e1629944980359-291x161.jpg" alt="" width="291" height="161" /><figcaption id="caption-attachment-963249" class="wp-caption-text">Filmmaker GuGu E. Michaels</figcaption></figure><p>Considerable kudos to Director and Screenplay author GuGu E. Michaels here. While his film features graphic sex, violence and consistently raw language, he includes in a frank and adult narrative an extended and pivotal scene of Sean tearfully delivering a prayer of salvation for him and his family.  This is an <em>extraordinarily</em> rare moment indeed in the secular film industry. And it is a deeply moving one.</p><h2>The Bad</h2><p>Running the better part of two hours, this story bogs down over too many stretches, calling mightily for much more haste to the pace and faster flow.</p><h2>Aiming squarely to Puncture The Politics of Fear</h2><p>A vast array of our American governmental bodies, both federal and state, have done one hell of a job paralyzing the populous through the politics of fear over the past year and a half of the Coronavirus pandemic. It is rough enough for the relatively stable among us. Imagine what Covid-19 can do to those who aren&#8217;t so sound of mind. And continues to.</p><p>While &#8220;Incubated&#8221; is, on face, a character study of a man completely at the mercy of menacing mental illness, Michaels dispatches a message that resonates with even more potency. Reckless and irresponsible fear-mongering on the part of those who should know better extracts a very real, and too often times devastating, emotional toll. One that impacts far beyond what the disease may, or may not, be wreaking upon the masses.</p><p>Remember how the medical information changed practically by the hour? Like, <em>last</em> hour.</p><h2>No names, not no Talent</h2><figure style="width: 291px" class="wp-caption alignright"><img src="https://www.themovieblog.com/wp-content/uploads/2021/08/12882411-chianti-jeconiah-e1629944550735-291x161.jpg" alt="" width="291" height="161" /><figcaption class="wp-caption-text">Actor Chianti Jeconiah</figcaption></figure><p>Michaels mines performances from his cast which are roundly genuine and thoroughly believable.  In particular, Chianti Jeconiah&#8217;s Sean is, at different turns, sad, serene, schizophrenic and, ultimately, strong.</p><h2><strong>Overall</strong></h2><p>&#8220;Incubated&#8221;&#8216;s final moments of family reconciliation, born of a present battling like hell to (quite literally in these scenes) beat down the past, are gripping.</p><p>And, as the measure of us continue striving to be during these testing times of seemingly relentless uncertainty, hopeful.</p><p>I invite you to enjoy all of my eclectic film reviews as “The Quick Flick Critic”, continually updated at <a class="vglnk" href="https://thequickflickcritic.blogspot.com/" rel="nofollow">https://thequickflickcritic.blogspot.com</a></p><div id="wpdevar_comment_3" style="width:100%;text-align:left;"> <span style="padding: 10px;font-size:18px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#1e73be;">Comment with Facebook</span><div class="fb-comments" data-href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" data-order-by="social" data-numposts="10" data-width="100%" style="display:block;"></div></div><div class="fb-like" data-href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div><link href="https://fonts.googleapis.com/css?family=Comfortaa:400,700" rel="stylesheet"><div id="review" class="review-wrapper wp-review-963244 wp-review-point-type wp-review-aqua-template wp-review-box-full-width"><div class="review-heading"><h5 class="review-title"> &#034;Incubated&#034; (2021): Madness marinating in a Mack Truck</h5></div><div class="review-total-wrapper"> <span class="review-total-box"><h5>Overall</h5><div>5.9/10</div> </span><div class="review-point review-total"><div class="review-result-wrapper" style="background-color: #f5d9e8;"><div class="review-result" style="width:59%; background-color: #de5ea4;"></div><div class="review-result-text" style="color: #8e74ea;">5.9/10</div></div></div></div><ul class="review-list"><li> <span>Acting - <span>6/10</span></span><div class="review-point"><div class="review-result-wrapper" style="background-color: #f5d9e8;"><div class="review-result" style="width:60%; background-color: #de5ea4;"></div><div class="review-result-text" style="color: #8e74ea;">6/10</div></div></div></li><li> <span>Cinematography/Visual Effects - <span>5.5/10</span></span><div class="review-point"><div class="review-result-wrapper" style="background-color: #f5d9e8;"><div class="review-result" style="width:55%; background-color: #de5ea4;"></div><div class="review-result-text" style="color: #8e74ea;">5.5/10</div></div></div></li><li> <span>Plot/Screenplay - <span>6/10</span></span><div class="review-point"><div class="review-result-wrapper" style="background-color: #f5d9e8;"><div class="review-result" style="width:60%; background-color: #de5ea4;"></div><div class="review-result-text" style="color: #8e74ea;">6/10</div></div></div></li><li> <span>Setting/Theme - <span>6.25/10</span></span><div class="review-point"><div class="review-result-wrapper" style="background-color: #f5d9e8;"><div class="review-result" style="width:63%; background-color: #de5ea4;"></div><div class="review-result-text" style="color: #8e74ea;">6.3/10</div></div></div></li></ul><div class="user-review-area visitors-review-area"><div class="wp-review-user-rating wp-review-user-rating-star"><div id="wp-review-star-rating-2519" class="wp-review-rating-input review-star" data-post-id="963244" data-token="5ccb56f006"><div class="wp-review-loading-msg"> <span class="animate-spin fa fa-spinner"></span> Sending</div><div class="review-result-wrapper"> <span data-input-value="1" title="1/5"><i class="mts-icon-star"></i></span><span data-input-value="2" title="2/5"><i class="mts-icon-star"></i></span><span data-input-value="3" title="3/5"><i class="mts-icon-star"></i></span><span data-input-value="4" title="4/5"><i class="mts-icon-star"></i></span><span data-input-value="5" title="5/5"><i class="mts-icon-star"></i></span><div class="review-result" style="width:0%;"> <i class="mts-icon-star"></i><i class="mts-icon-star"></i><i class="mts-icon-star"></i><i class="mts-icon-star"></i><i class="mts-icon-star"></i></div></div> <input type="hidden" class="wp-review-user-rating-val" name="wp-review-user-rating-val" value="0.0" /> <input type="hidden" class="wp-review-user-rating-nonce" value="5ccb56f006" /> <input type="hidden" class="wp-review-user-rating-postid" value="963244" /></div></div><div class="user-total-wrapper"><h5 class="user-review-title">User Review</h5> <span class="review-total-box"> <span class="wp-review-user-rating-total">0</span> <small>(<span class="wp-review-user-rating-counter">0</span> votes)</small> </span></div></div><div class="review-desc"><p class="review-summary-title"><strong>&#34;Incubated&#34; (2021): Madness marinating in a Mack Truck</strong></p><p>While &#8220;Incubated&#8221; is, on face, a character study of a man completely at the mercy of menacing mental illness, Michaels dispatches a message that resonates with even more potency.</p></div><ul class="review-links"><li> <a href="https://thequickflickcritic.blogspot.com/2021/08/new-content-incubated-2021-added-to.html" target="_blank">***NEW CONTENT! &#034;INCUBATED&#034; (2021) added to &#034;DRAMA&#034; on 8/25/21***</a></li></ul></div> <script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "Review",
"itemReviewed": {
"@type": "Thing",
"name": "&#034;Incubated&#034; (2021): Madness marinating in a Mack Truck"
},
"reviewRating": {
"@type": "Rating",
"ratingValue": "5.9",
"bestRating": 10
},
"author": {
"@type": "Person",
"name": "John Smistad"
},
"reviewBody": "While &quot;Incubated&quot; is, on face, a character study of a man completely at the mercy of menacing mental illness, Michaels dispatches a message that resonates with even more potency."
}</script> </div><footer class="single-entry-footer"> <span class="categorized-under">Posted Under</span><div class="awaken-category-list"><a href="https://www.themovieblog.com/category/features/reviews/" rel="category tag">Reviews</a></div><div class="clearfix"></div><span class="tagged-under">Tagged</span><div class="awaken-tag-list"><a href="https://www.themovieblog.com/tag/drama/" rel="tag">Drama</a> <a href="https://www.themovieblog.com/tag/incubated/" rel="tag">Incubated</a> <a href="https://www.themovieblog.com/tag/mental-illness/" rel="tag">mental illness</a> <a href="https://www.themovieblog.com/tag/new-film/" rel="tag">new film</a></div><div class="clearfix"></div><div class="awp-shareicons"><div class="awp-shareicon-set"><a class="social-link awp-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F" target="_blank"><i class="fa fa-facebook"></i><span class="ss-text">Share on facebook</span></a><a class="social-link awp-twitter" href="https://twitter.com/intent/tweet?text=&#8220;Incubated&#8221;%20(2021):%20Madness%20marinating%20in%20a%20Mack%20Truck&amp;url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F" target="_blank"><i class="fa fa-twitter"></i><span class="ss-text">Tweet on twitter</span></a><a class="social-link awp-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F" target="_blank"><i class="fa fa-google-plus"></i></a><a class="social-link awp-whatsapp" href="whatsapp://send?text=&#8220;Incubated&#8221;%20(2021):%20Madness%20marinating%20in%20a%20Mack%20Truck https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F" target="_blank"><i class="fa fa-instagram"></i></a><a class="social-link awp-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F&amp;title=&#8220;Incubated&#8221;%20(2021):%20Madness%20marinating%20in%20a%20Mack%20Truck" target="_blank"><i class="fa fa-linkedin"></i></a><a class="social-link awp-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.themovieblog.com%2F2021%2F08%2Fincubated-2021-madness-marinating-in-a-mack-truck%2F&amp;media=https://www.themovieblog.com/wp-content/uploads/2021/08/incubated-2021.jpg&amp;description=&#8220;Incubated&#8221;%20(2021):%20Madness%20marinating%20in%20a%20Mack%20Truck" target="_blank"><i class="fa fa-pinterest"></i></a></div></div></footer></article><div class="media profile"> <img alt='' src='https://secure.gravatar.com/avatar/12f078bd62e7bcaebc75aaae62fd5834?s=70&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/12f078bd62e7bcaebc75aaae62fd5834?s=140&#038;d=mm&#038;r=pg 2x' class='avatar avatar-70 photo' height='70' width='70' /><div class="bd"><h4>About John Smistad</h4><p>I am a voracious writer of Movie Reviews. Check 'em out at my Blog, "The Quick Flick Critic", @: <a href="https://thequickflickcritic.blogspot.com/">The Quick Flick Critic</a> Thanks guys! 
John</p><div class="profile-links"><ul class="social-links"><li><a class="sociall" href="https://twitter.com/@QwikFlickCritic" data-toggle="tooltip" data-placement="top" title="Follow John Smistad on Twitter"><i class="fa fa-twitter-square"></i></a></li><li><a class="sociall" href="https://www.linkedin.com/in/johnsmistad/" data-toggle="tooltip" data-placement="top" title="Follow John Smistad on LinkedIn"><i class="fa fa-linkedin-square"></i></a></li><li><a class="sociall" href="https://plus.google.com/+ThequickflickcriticBlogspotalwaysupdated?hl=en" data-toggle="tooltip" data-placement="top" title="Follow John Smistad on Google+"><i class="fa fa-google-plus-square"></i></a></li></ul> <a class="authorlla" href="https://www.themovieblog.com/author/john-smistad/"> View all posts by John Smistad <span class="meta-nav">&rarr;</span> </a></div></div></div><nav class="navigation post-navigation" role="navigation"><h1 class="screen-reader-text">Post navigation</h1><div class="nav-links"><div class="nav-previous"><a href="https://www.themovieblog.com/2021/08/why-horror-is-so-hard-to-get-right/" rel="prev">Why Horror Is So Hard to Get Right</a></div></div></nav><div class="related-posts clearfix"><h2>You may like these posts</h2><div class="awaken-related-posts"><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/"><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2021/08/incubated-2021-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2021/08/incubated-2021-madness-marinating-in-a-mack-truck/">&#8220;Incubated&#8221; (2021): Madness marinating in a Mack Truck</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2021/08/shang-chi-review/"><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2021/08/BUS3520_cmp_lum_v0045.1069_R-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2021/08/shang-chi-review/">Shang Chi Review: Marvel&#8217;s Best Action Movie Hits More Than It Misses</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2021/08/he-who-remains-iron-lad-nathaniel-richards/"><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2021/08/IRON-LAD-EXPLAINED-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="Iron Lad Explained" /></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2021/08/he-who-remains-iron-lad-nathaniel-richards/">He Who Remains | Iron Lad | Nathaniel Richards</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2021/08/message-of-tolerance-reverberates-in-joe-bell-2021/"><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2021/08/Good-Joe-Bell-movie-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2021/08/message-of-tolerance-reverberates-in-joe-bell-2021/">Message of Tolerance Reverberates in &#8220;Joe Bell&#8221; (2021)</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2021/08/the-night-house-review/"><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2021/08/029_TNH-SG-01183-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2021/08/the-night-house-review/">The Night House Review: Rebecca Hall Is Remarkable In This Odd Horror</a></h3></div></article></div></div><div id="disqus_thread"></div></main></div></div><div class="col-xs-12 col-sm-6 col-md-4 awaken-widgets-float"><div id="secondary" class="main-widget-area" role="complementary"><aside id="awaken_pro_video_widget-2" class="widget widget_awaken_pro_video_widget"><div class="widget-title-container"><h2 class="widget-title">TMB on YouTube</h2></div><div class="awaken-video-widget video-container"> <iframe width="100%" height="100%" src="https://www.youtube.com/embed/pvYx6VwSvcc" frameborder="0" allowfullscreen></iframe></div></aside><aside id="search-6" class="widget widget_search"><div class="widget-title-container"><h2 class="widget-title">Search The Movie Blog</h2></div><form role="search" method="get" class="search-form" action="https://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside><aside id="facebook-like-widget-4" class="widget widget_facebook-like-widget"><div class="widget-title-container"><h2 class="widget-title">Find us on Facebook</h2></div> <iframe src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FTheMovieBlogOnline%2F&amp;width=360&amp;colorscheme=light&amp;show_faces=true&amp;stream=true&amp;header=false&amp;height=600" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:360px; height: 600px; background: #FFF;"></iframe></aside><aside id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-title-container"><h2 class="widget-title">Reader Comments</h2></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Ryan Smith</span> on <a href="https://www.themovieblog.com/2021/08/obi-wan-kenobi-the-star-wars-series-we-cant-wait-to-see-in-2022/#comment-382231">Obi-Wan Kenobi: The Star Wars Series We Can’t Wait To See In 2022</a></li><li class="recentcomments"><span class="comment-author-link">Chudvamanuel</span> on <a href="https://www.themovieblog.com/2021/04/loki-trailer-reaction/#comment-382207">Loki Trailer Reaction</a></li><li class="recentcomments"><span class="comment-author-link">Marijuana babe ChudwaLinda</span> on <a href="https://www.themovieblog.com/2021/04/without-remorse-giveaway/#comment-382190">How To See &#8220;Tom Clancy&#8217;s Without Remorse&#8221; Early and FREE!</a></li><li class="recentcomments"><span class="comment-author-link">Lundmay Anand's babe Chudvankita Misra</span> on <a href="https://www.themovieblog.com/2021/08/best-movies-set-in-the-great-depression-era/#comment-382163">Best movies set in the Great Depression era</a></li><li class="recentcomments"><span class="comment-author-link">A choot in the Lund</span> on <a href="https://www.themovieblog.com/2021/08/football-players-who-have-starred-in-movies-tv-shows/#comment-382162">Football Players Who Have Starred in Movies/TV Shows</a></li></ul></aside><aside id="linkcat-2" class="widget widget_links"><div class="widget-title-container"><h2 class="widget-title">Blogroll</h2></div><ul class='xoxo blogroll'><li><a href="http://moviesblog.mtv.com/" target="_blank">MTV Movies Blog</a></li><li><a href="http://www.firstshowing.net" target="_blank">First Showing</a></li><li><a href="https://www.slashfilm.com" target="_blank">/Film</a></li><li><a href="http://www.screenrant.com" target="_blank">Screenrant</a></li><li><a href="http://www.filmschoolrejects.com" target="_blank">FilmSchoolRejects</a></li><li><a href="http://www.filmfad.com/" rel="acquaintance colleague" title="Film Fad &#8211; Ryan Brown" target="_blank">Film Fad</a></li><li><a href="http://www.WeeklyWilson.com">Weekly Wilson</a></li></ul></aside><aside id="text-3" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside><aside id="text-2" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside></div></div></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="container"><div class="row"><div class="footer-widget-area"><div class="col-md-4"><div class="left-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="pages-6" class="widget widget_pages"><h2 class="footer-widget-title">Learn More</h2><ul><li class="page_item page-item-2"><a href="https://www.themovieblog.com/about/">About</a></li><li class="page_item page-item-7922"><a href="https://www.themovieblog.com/contact/">Contact Us</a></li></ul></aside></div></div></div><div class="col-md-4"><div class="mid-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="search-4" class="widget widget_search"><h2 class="footer-widget-title">Find What You&#8217;re Looking For</h2><form role="search" method="get" class="search-form" action="https://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="col-md-4"><div class="right-footer"><div id="secondary" class="widget-area" role="complementary"></div></div></div></div></div></div><div class="footer-site-info"><div class="container"> <span class="sep"> | </span></div></div></footer></div><div id="fb-root"></div> <script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=213014669302515&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <div id="fb-root"></div><script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7&appId=293076464454881";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <!-- <link rel='stylesheet' id='dashicons-css'  href='https://www.themovieblog.com/wp-includes/css/dashicons.min.css?ver=5.4.6' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/9k8gom7u/dctvs.css" media="all"/> <script type='text/javascript'>var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"963244 https:\/\/www.themovieblog.com\/?p=963244","disqusShortname":"therealmovieblog","disqusTitle":"\u201cIncubated\u201d (2021): Madness marinating in a Mack Truck","disqusUrl":"https:\/\/www.themovieblog.com\/2021\/08\/incubated-2021-madness-marinating-in-a-mack-truck\/","postId":"963244"};</script> <script type='text/javascript'>var countVars = {"disqusShortname":"therealmovieblog"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"963244 https:\/\/www.themovieblog.com\/?p=963244","disqusShortname":"therealmovieblog","disqusTitle":"\u201cIncubated\u201d (2021): Madness marinating in a Mack Truck","disqusUrl":"https:\/\/www.themovieblog.com\/2021\/08\/incubated-2021-madness-marinating-in-a-mack-truck\/","postId":"963244"};
var dclCustomVars = {"dcl_progress_text":"Go Go Gadget Comments!"};</script> <script type='text/javascript'>var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript'>var wpreview = {"ajaxurl":"https:\/\/www.themovieblog.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript'>var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.themovieblog.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};</script> <script defer src="https://www.themovieblog.com/wp-content/cache/autoptimize/js/autoptimize_6053554d9ea2afd8a2e5603db980eebe.js"></script></body></html><!-- WP Fastest Cache file was created in 0.795841932297 seconds, on 25-08-21 23:09:08 -->