<!DOCTYPE html><html lang="en-US"
xmlns:og="http://opengraphprotocol.org/schema/"
xmlns:fb="http://www.facebook.com/2008/fbml"><head>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-34813422-1"></script> <script>window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-34813422-1');</script> <meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://www.themovieblog.com/xmlrpc.php"> <script data-cfasync="false" data-no-defer="1">var ewww_webp_supported=!1;function check_webp_feature(A,e){var w;e=void 0!==e?e:function(){},ewww_webp_supported?e(ewww_webp_supported):((w=new Image).onload=function(){ewww_webp_supported=0<w.width&&0<w.height,e&&e(ewww_webp_supported)},w.onerror=function(){e&&e(!1)},w.src="data:image/webp;base64,"+{alpha:"UklGRkoAAABXRUJQVlA4WAoAAAAQAAAAAAAAAAAAQUxQSAwAAAARBxAR/Q9ERP8DAABWUDggGAAAABQBAJ0BKgEAAQAAAP4AAA3AAP7mtQAAAA=="}[A])}check_webp_feature("alpha");</script><script data-cfasync="false" data-no-defer="1">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</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta property="og:title" content="Chicago: Strange World Advance Screening Giveaway"/><meta property="og:description" content="Would you like to see Strange World, starring Jake Gyllenhaal, Dennis Quaid, Gabrielle Union, and more?  Would you like to see it early and free? Enter for the"/><meta property="og:image" content="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K.jpg"/><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Chicago: Strange World Advance Screening Giveaway"/><meta name="twitter:description" content="Would you like to see Strange World, starring Jake Gyllenhaal, Dennis Quaid, Gabrielle Union, and more?  Would you like to see it early and free? Enter for the"/><meta name="twitter:image" content="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K.jpg"/><meta name="author" content="Emmanuel &quot;E-Man&quot; Noisette"/><!-- <link media="all" href="https://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_59ec834f556379536598b9962bee6fa0.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/keg8qq2s/9jmzs.css" media="all"/><!-- <link media="screen" href="https://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_2baad7f35bbed7a951e82f6c7abca532.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/scgm7mv/dctvs.css" media="screen"/><title>Chicago: Strange World Advance Screening Giveaway</title><meta name="description" content="Chicago! Would you like to see Strange World, starring Jake Gyllenhaal, Dennis Quaid, Gabrielle Union, and more?  Grab your pass now!" /><link rel="canonical" href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" /><meta property="og:url" content="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" /><meta property="og:site_name" content="The Movie Blog" /><meta property="article:publisher" content="https://www.facebook.com/TheMovieBlogOnline/" /><meta property="article:author" content="https://www.facebook.com/EmansReviews/" /><meta property="article:published_time" content="2022-11-21T19:46:37+00:00" /><meta property="article:modified_time" content="2022-11-21T19:47:35+00:00" /><meta property="og:image" content="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="804" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Emmanuel &quot;E-Man&quot; Noisette" /><meta name="twitter:creator" content="@EmansReviews" /><meta name="twitter:site" content="@tmb_tweets" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Emmanuel "E-Man" Noisette" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Feed" href="https://www.themovieblog.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Comments Feed" href="https://www.themovieblog.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Chicago: Strange World Advance Screening Giveaway Comments Feed" href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.themovieblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='awaken-pro-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu%3Aregular%2Citalic%2C700%2C500|Roboto+Condensed%3Aregular%2Citalic%2C700|Source+Sans+Pro%3Aregular%2Citalic%2C700%26subset%3Dlatin%2Clatin' type='text/css' media='screen' /> <script src='//www.themovieblog.com/wp-content/cache/wpfc-minified/7ngvu3dd/hn4ai.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://www.themovieblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> --> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/respond.min.js?ver=6.0.3' id='respond-js'></script> <![endif]--> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/html5shiv.js?ver=6.0.3' id='html5shiv-js'></script> <![endif]--><link rel="https://api.w.org/" href="https://www.themovieblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.themovieblog.com/wp-json/wp/v2/posts/973594" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.themovieblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.themovieblog.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 6.0.3" /><link rel='shortlink' href='https://www.themovieblog.com/?p=973594' /><link rel="alternate" type="application/json+oembed" href="https://www.themovieblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.themovieblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F&#038;format=xml" /><meta property="fb:app_id" content="213014669302515"/><meta property="fb:pages" content="336692746071 " /><meta property="og:locale" content="en_US" /><meta property="og:locale:alternate" content="en_US" /><meta property="fb:app_id" content="293076464454881" /><meta property="og:site_name" content="The Movie Blog" /><meta property="og:title" content="Chicago: Strange World Advance Screening Giveaway" /><meta property="og:url" content="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" /><meta property="og:description" content="Would you like to see Strange World, starring Jake Gyllenhaal, Dennis Quaid, Gabrielle Union, and more?  Would you like to see it early and free? Enter for the chance to grab a free pass to the advanced screening of Strange World. Passes are given on a first-come, first-serve basis. Hurry&lt;a class=&quot;moretag&quot; href=&quot;https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/&quot;&gt; ... [Read More]&lt;/a&gt;" /><meta property="og:type" content="Article" /><link rel="icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-180x180.png" /><meta name="msapplication-TileImage" content="https://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-270x270.png" /></head><body class="post-template-default single single-post postid-973594 single-format-standard group-blog ">
<script data-cfasync="false" data-no-defer="1">if(typeof ewww_webp_supported==="undefined"){var ewww_webp_supported=!1}if(ewww_webp_supported){document.body.classList.add("webp-support")}</script><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><div class="top-nav"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 "><nav id="top-navigation" class="top-navigation" role="navigation"><div class="menu-social-bot-container"><ul id="menu-social-bot" class="menu"><li id="menu-item-229450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229450"><a href="https://www.facebook.com/pages/The-Movie-Blog-Fan-Page/336692746071">Facebook</a></li><li id="menu-item-947974" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-947974"><a href="https://www.instagram.com/themovieblogonline">Instagram</a></li><li id="menu-item-229448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229448"><a href="https://www.twitter.com/TMB_Tweets">Twitter</a></li><li id="menu-item-229452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229452"><a href="https://www.themovieblog.com/feed">RSS</a></li></ul></div></nav> <a href="#" class="navbutton" id="top-nav-button">Top Menu</a><div class="responsive-topnav"></div></div><div class="col-xs-12 col-sm-12 col-md-4"><div class="asocial-area"> <span class="asocial-icon facebook"><a href="https://www.facebook.com/TheMovieBlogOnline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Facebook" target="_blank"><i class="fa fa-facebook"></i></a></span> <span class="asocial-icon twitter"><a href="https://twitter.com/tmb_tweets?lang=en" data-toggle="tooltip" data-placement="bottom" title="Find us on Twitter" target="_blank"><i class="fa fa-twitter"></i></a></span> <span class="asocial-icon youtube"><a href="https://www.youtube.com/c/Themovieblog?sub_confirmation=1" data-toggle="tooltip" data-placement="bottom" title="Find us on Youtube" target="_blank"><i class="fa fa-youtube"></i></a></span> <span class="asocial-icon rss"><a href="https://www.themovieblog.com/feed" data-toggle="tooltip" data-placement="bottom" title="Find us on RSS" target="_blank"><i class="fa fa-rss"></i></a></span> <span class="asocial-icon instagram"><a href="https://www.instagram.com/themovieblogonline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Instagram" target="_blank"><i class="fa fa-instagram"></i></a></span></div></div></div></div></div><div class="site-branding"><div class="container"><div class="site-brand-container"><div class="site-title-text"><h1 class="site-title"><a href="https://www.themovieblog.com/" rel="home">The Movie Blog</a></h1><h2 class="site-description">The Official Home of Correct Movie Opinions</h2></div></div><div class="header-ad-area"><div id="secondary" class="widget-area" role="complementary"><aside id="text-12" class="widget widget_text"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-1282480773966371"
data-ad-slot="7135789799"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div></div></div></div><div class="container"><div class="awaken-navigation-container"><nav id="site-navigation" class="main-navigation cl-effect-10" role="navigation"><div class="menu-browse-container"><ul id="menu-browse" class="menu"><li id="menu-item-960452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-960452"><a href="https://teespring.com/stores/themovieblog">Shop</a></li><li id="menu-item-229439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229439"><a href="https://www.themovieblog.com/category/uncategorized/">News Chat</a></li><li id="menu-item-229440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229440"><a href="https://www.themovieblog.com/category/features/reviews/">Reviews</a></li><li id="menu-item-229443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229443"><a href="https://www.themovieblog.com/category/features/interviews/">Interviews</a></li><li id="menu-item-918311" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-918311"><a href="https://www.themovieblog.com/category/features/">Features</a></li><li id="menu-item-229441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229441"><a href="https://www.themovieblog.com/category/features/trailers/">Trailers</a></li><li id="menu-item-947973" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-947973"><a href="https://www.themovieblog.com/category/features/contests/">Contests</a></li><li id="menu-item-931821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931821"><a href="https://www.themovieblog.com/contact/">Contact Us</a></li><li id="menu-item-931822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931822"><a href="https://www.themovieblog.com/about/">About</a></li></ul></div></nav> <a href="#" class="navbutton" id="main-nav-button">Main Menu</a><div class="responsive-mainnav"></div><div class="awaken-search-button-icon"></div><div class="awaken-search-box-container"><div class="awaken-search-box"><form action="https://www.themovieblog.com/" id="awaken-search-form" method="get"> <input type="text" value="" name="s" id="s" /> <input type="submit" value="Search" /></form></div></div></div></div></header><div id="content" class="site-content"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 awaken-content-float"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><article id="post-973594" class="post-973594 post type-post status-publish format-standard has-post-thumbnail hentry category-contests tag-strange-world"><header class="single-entry-header"><h1 class="single-entry-title">Chicago: Strange World Advance Screening Giveaway</h1><div class="single-entry-meta"> <span class="posted-on"><a href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" rel="bookmark"><time class="entry-date published" datetime="2022-11-21T14:46:37-05:00">November 21, 2022</time><time class="updated" datetime="2022-11-21T14:47:35-05:00">November 21, 2022</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="https://www.themovieblog.com/author/emansmoviereviews/">Emmanuel &quot;E-Man&quot; Noisette</a></span></span> <span class="comments-link"><a href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="973594 https://www.themovieblog.com/?p=973594">Leave a comment</span></a></span></div></header><div class="article-featured-image"> <picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K-752x440.jpg.webp"  type='image/webp'><img width="752" height="440" src="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K-752x440.jpg" class="attachment-featured-slider size-featured-slider wp-post-image" alt="" data-eio="p" /></picture></div><div class="entry-content"><div class="fb-like" data-href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div><p>Would you like to see <b><i>Strange World</i></b><i>, </i>starring Jake Gyllenhaal, Dennis Quaid, Gabrielle Union, and more?  <a href="https://www.themovieblog.com/category/features/contests/" target="_blank" rel="noopener">Would you like to see it early and free</a>? Enter for the chance to grab a free pass to the advanced screening of <b><i>Strange World</i></b>. Passes are given on a first-come, first-serve basis. Hurry and grab your pass before they&#8217;re all gone.</p><figure id="attachment_973685" aria-describedby="caption-attachment-973685" style="width: 747px" class="wp-caption alignleft"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-1024x429.jpg.webp 1024w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-594x249.jpg.webp 594w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-768x322.jpg.webp 768w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-1536x643.jpg.webp 1536w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K.jpg.webp 1920w" sizes='(max-width: 747px) 100vw, 747px' type='image/webp'><img loading="lazy" class="size-large wp-image-973685" src="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-1024x429.jpg" alt="" width="747" height="313" srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-1024x429.jpg 1024w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-594x249.jpg 594w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-768x322.jpg 768w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K-1536x643.jpg 1536w, https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Can_I_Call_You_Splat_243.0_053.00_0017B_2K.jpg 1920w" sizes="(max-width: 747px) 100vw, 747px" data-eio="p" /></picture><figcaption id="caption-attachment-973685" class="wp-caption-text">STRANGE WORLD</figcaption></figure><h2><b>How To Enter the Giveaway:</b></h2><p><a href="https://gofobo.com/TMBstrange">Click Here To Enter</a></p><h3><b>Screener Details</b></h3><p>Downtown Chicago<br /> Monday, November 21 2022<br /> 6:30PM</p><h2>About <em>STRANGE WORLD</em>:</h2><div class="MuiTypography-root-139 jss47 jss184 jss47 Hawkins-Text-default jss185 jss187 jss194 MuiTypography-body1-141"><p class="m_3225472972863922278yiv8049513648msonormal">Walt Disney Animation Studios’ original action-packed adventure “Strange World” introduces a legendary family of explorers, the Clades, as they attempt to navigate an uncharted, treacherous land alongside a motley crew that includes a mischievous blob, a three-legged dog and a slew of ravenous creatures. The voice cast includes Jake Gyllenhaal as Searcher Clade, a family man who finds himself out of his element on an unpredictable mission; Dennis Quaid as Searcher’s larger-than-life explorer father, Jaeger; Jaboukie Young-White as Searcher’s 16-year-old son, Ethan, who longs for adventure; Gabrielle Union as Meridian Clade, an accomplished pilot and Searcher’s partner in all things; and Lucy Liu as Callisto Mal, Avalonia’s fearless leader who spearheads the exploration into the strange world. Helmed by Don Hall (Oscar®-winning “Big Hero 6,” “Raya and the Last Dragon”) and co-director/writer Qui Nguyen (co-writer “Raya and the Last Dragon”), and produced by <u></u><u></u></p></div><h2><em><strong><b>STRANGE WORLD</b> Trailer</strong></em>:</h2><p><iframe loading="lazy" title="Strange World | Official Trailer" width="747" height="420" src="https://www.youtube.com/embed/bKh2G73gCCs?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-691x1024.jpg.webp 691w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-594x880.jpg.webp 594w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-768x1138.jpg.webp 768w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world.jpg.webp 1012w" sizes='(max-width: 691px) 100vw, 691px' type='image/webp'><img loading="lazy" class="size-large wp-image-973682 aligncenter" src="https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-691x1024.jpg" alt="" width="691" height="1024" srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-691x1024.jpg 691w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-594x880.jpg 594w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world-768x1138.jpg 768w, https://www.themovieblog.com/wp-content/uploads/2022/11/strange-world-movie-world.jpg 1012w" sizes="(max-width: 691px) 100vw, 691px" data-eio="p" /></picture></p><blockquote><p style="text-align: center;"><strong>Director: </strong>Don Hall<span class="m_3225472972863922278apple-converted-space"> &amp; Qui Nguyen</span><br /> <strong>Writer(s): </strong><span class="m_3225472972863922278apple-converted-space">Qui Nguyen</span><br /> <strong>Stars:</strong> Jake Gyllenhaal, Dennis Quaid, Jaboukie Young-White, Gabrielle Union, Lucy Liu<br /> <b><i>STRANGE WORLD  </i></b>hits theaters on November 23, 2022. Be sure to follow <a href="http://www.Facebook.com/EmansReviews">E-Man’s Movie Reviews</a> on Facebook, <a href="http://www.Youtube.com/EmansMovieReviews">Subscribe on YouTube</a>, or follow me on Twitter/IG @EmansReviews for even more movie news and reviews!</p></blockquote><div id="wpdevar_comment_2" style="width:100%;text-align:left;"> <span style="padding: 10px;font-size:18px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#1e73be;">Comment with Facebook</span><div class="fb-comments" data-href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" data-order-by="social" data-numposts="10" data-width="100%" style="display:block;"></div></div><div class="fb-like" data-href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div></div><footer class="single-entry-footer"> <span class="categorized-under">Posted Under</span><div class="awaken-category-list"><a href="https://www.themovieblog.com/category/features/contests/" rel="category tag">Contests</a></div><div class="clearfix"></div><span class="tagged-under">Tagged</span><div class="awaken-tag-list"><a href="https://www.themovieblog.com/tag/strange-world/" rel="tag">Strange World</a></div><div class="clearfix"></div><div class="awp-shareicons"><div class="awp-shareicon-set"><a class="social-link awp-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F" target="_blank"><i class="fa fa-facebook"></i><span class="ss-text">Share on facebook</span></a><a class="social-link awp-twitter" href="https://twitter.com/intent/tweet?text=Chicago:%20Strange%20World%20Advance%20Screening%20Giveaway&amp;url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F" target="_blank"><i class="fa fa-twitter"></i><span class="ss-text">Tweet on twitter</span></a><a class="social-link awp-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F" target="_blank"><i class="fa fa-google-plus"></i></a><a class="social-link awp-whatsapp" href="whatsapp://send?text=Chicago:%20Strange%20World%20Advance%20Screening%20Giveaway https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F" target="_blank"><i class="fa fa-instagram"></i></a><a class="social-link awp-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F&amp;title=Chicago:%20Strange%20World%20Advance%20Screening%20Giveaway" target="_blank"><i class="fa fa-linkedin"></i></a><a class="social-link awp-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F&amp;media=https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K.jpg&amp;description=Chicago:%20Strange%20World%20Advance%20Screening%20Giveaway" target="_blank"><i class="fa fa-pinterest"></i></a></div></div></footer></article><div class="media profile"> <img alt='' src='https://secure.gravatar.com/avatar/c50f1bec37f2d25afab9290c4f498c50?s=70&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/c50f1bec37f2d25afab9290c4f498c50?s=140&#038;d=mm&#038;r=pg 2x' class='avatar avatar-70 photo' height='70' width='70' loading='lazy'/><div class="bd"><h4>About Emmanuel "E-Man" Noisette</h4><p>Emmanuel is a Chicago film critic who founded <a href="http://www.Emansmoviereviews.com">Eman's Movie Reviews</a>. He  freelances as a writer and video content creator for sites such as MovieTickets.com. Be sure to join the other 33K+ fans on his <a href="https://www.facebook.com/EmansReviews/">Facebook Fan Page</a> for even more movie opinions and fun. Feel free to contact him with any professional inquiries: <a href="/cdn-cgi/l/email-protection#eaaf878b84aaaf878b8499a7859c838fb88f9c838f9d99c4898587"><span class="__cf_email__" data-cfemail="e5a088848ba5a088848b96a88a938c80b780938c809296cb868a88">[email&#160;protected]</span></a></p><div class="profile-links"><ul class="social-links"><li><a class="sociall" href="https://twitter.com/@EmansReviews" data-toggle="tooltip" data-placement="top" title="Follow Emmanuel "E-Man" Noisette on Twitter"><i class="fa fa-twitter-square"></i></a></li><li><a class="sociall" href="https://www.facebook.com/EmansReviews/" data-toggle="tooltip" data-placement="top" title="Follow Emmanuel "E-Man" Noisette on Facebook"><i class="fa fa-facebook-square"></i></a></li></ul> <a class="authorlla" href="https://www.themovieblog.com/author/emansmoviereviews/"> View all posts by Emmanuel "E-Man" Noisette <span class="meta-nav">&rarr;</span> </a></div></div></div><nav class="navigation post-navigation" role="navigation"><h1 class="screen-reader-text">Post navigation</h1><div class="nav-links"><div class="nav-previous"><a href="https://www.themovieblog.com/2022/11/bob-iger-back-as-ceo-at-disney/" rel="prev">Bob Iger Back as CEO at Disney</a></div></div></nav><div class="related-posts clearfix"><h2>You may like these posts</h2><div class="awaken-related-posts"><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K-120x85.jpg.webp"  type='image/webp'><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2022/11/STRANGE_WORLD-ONLINE-USE-Lost_And_Found_240.0_004.00_0333_2K-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" loading="lazy" data-eio="p" /></picture></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2022/11/chicago-strange-world-advance-screening-giveaway/">Chicago: Strange World Advance Screening Giveaway</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2022/11/chicago-violent-night-advance-screening-giveaway/"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/2561_D006_00161R_CROP-120x85.jpg.webp"  type='image/webp'><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2022/11/2561_D006_00161R_CROP-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" loading="lazy" data-eio="p" /></picture></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2022/11/chicago-violent-night-advance-screening-giveaway/">Chicago: Violent Night Advance Screening Giveaway</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2022/11/the-fabelmans-chicago-advance-screening/"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/11/The-Fabelmans-movie-1-120x85.jpg.webp"  type='image/webp'><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2022/11/The-Fabelmans-movie-1-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" loading="lazy" data-eio="p" /></picture></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2022/11/the-fabelmans-chicago-advance-screening/">Chicago: The Fabelmans Advance Screening Giveaway</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2022/10/chicago-wednesday-advance-screening/"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/10/Wednesday-Addams-Netflix-3-120x85.jpg.webp"  type='image/webp'><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2022/10/Wednesday-Addams-Netflix-3-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" loading="lazy" data-eio="p" /></picture></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2022/10/chicago-wednesday-advance-screening/">Chicago: WEDNESDAY Advance Screening</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="https://www.themovieblog.com/2022/10/wendell-wild-advance-screening-giveaway/"><picture><source srcset="https://www.themovieblog.com/wp-content/uploads/2022/10/wendell-Wild-netflix-1-120x85.jpg.webp"  type='image/webp'><img width="120" height="85" src="https://www.themovieblog.com/wp-content/uploads/2022/10/wendell-Wild-netflix-1-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" loading="lazy" data-eio="p" /></picture></a></div><div id="related-posts-title"><h3><a href="https://www.themovieblog.com/2022/10/wendell-wild-advance-screening-giveaway/">WENDELL &#038; WILD Advance Screening Giveaway</a></h3></div></article></div></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/11/chicago-strange-world-advance-screening-giveaway/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.themovieblog.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.themovieblog.com%2F2022%2F11%2Fchicago-strange-world-advance-screening-giveaway%2F">logged in</a> to post a comment.</p></div></div></main></div></div><div class="col-xs-12 col-sm-6 col-md-4 awaken-widgets-float"><div id="secondary" class="main-widget-area" role="complementary"><aside id="awaken_pro_video_widget-2" class="widget widget_awaken_pro_video_widget"><div class="widget-title-container"><h2 class="widget-title">TMB on YouTube</h2></div><div class="awaken-video-widget video-container"> <iframe width="100%" height="100%" src="https://www.youtube.com/embed/gwhPZ3047io" frameborder="0" allowfullscreen></iframe></div></aside><aside id="search-6" class="widget widget_search"><div class="widget-title-container"><h2 class="widget-title">Search The Movie Blog</h2></div><form role="search" method="get" class="search-form" action="https://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside><aside id="facebook-like-widget-4" class="widget widget_facebook-like-widget"><div class="widget-title-container"><h2 class="widget-title">Find us on Facebook</h2></div> <iframe src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FTheMovieBlogOnline%2F&amp;width=360&amp;colorscheme=light&amp;show_faces=true&amp;stream=true&amp;header=false&amp;height=600" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:360px; height: 600px; background: #FFF;"></iframe></aside><aside id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-title-container"><h2 class="widget-title">Reader Comments</h2></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Amelia</span> on <a href="https://www.themovieblog.com/2022/10/casino-based-on-a-true-story-shocking-facts-about-casino-real-story/#comment-412292">Casino Based On A True Story? Shocking Facts About Casino Real Story</a></li><li class="recentcomments"><span class="comment-author-link">matrudon20</span> on <a href="https://www.themovieblog.com/2022/11/homemade-smoothie-recipes-you-need-to-try-this-season/#comment-410440">Homemade Smoothie Recipes You Need to Try This Season</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://cinemak.pl/' rel='external nofollow ugc' class='url'>cinemak.pl</a></span> on <a href="https://www.themovieblog.com/2008/06/20-tips-for-starting-your-own-movie-blog/#comment-408965">20 Tips For Starting Your Own Movie Blog</a></li><li class="recentcomments"><span class="comment-author-link">vardhnam</span> on <a href="https://www.themovieblog.com/2022/11/lupita-nyongo-is-headed-to-a-quiet-place/#comment-408906">Lupita Nyong&#8217;o is headed to A Quiet Place</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://Collaboration%20For%20Guest%20Posting%20Websites' rel='external nofollow ugc' class='url'>Muhammadsufyan</a></span> on <a href="https://www.themovieblog.com/2022/10/elevate-your-movie-nights-with-these-affordable-home-theater-upgrades/#comment-408711">Elevate Your Movie Nights with These Affordable Home Theater Upgrades</a></li></ul></aside><aside id="linkcat-2" class="widget widget_links"><div class="widget-title-container"><h2 class="widget-title">Blogroll</h2></div><ul class='xoxo blogroll'><li><a href="http://moviesblog.mtv.com/" rel="noopener" target="_blank">MTV Movies Blog</a></li><li><a href="http://www.firstshowing.net" rel="noopener" target="_blank">First Showing</a></li><li><a href="https://www.slashfilm.com" rel="noopener" target="_blank">/Film</a></li><li><a href="http://www.screenrant.com" rel="noopener" target="_blank">Screenrant</a></li><li><a href="http://www.filmschoolrejects.com" rel="noopener" target="_blank">FilmSchoolRejects</a></li><li><a href="http://www.filmfad.com/" rel="acquaintance colleague noopener" title="Film Fad &#8211; Ryan Brown" target="_blank">Film Fad</a></li><li><a href="http://www.WeeklyWilson.com">Weekly Wilson</a></li><li><a href="https://www.togel55.co/" rel="noopener" target="_blank">Agen Togel</a></li><li><a href="https://www.goal55.id/" rel="noopener" target="_blank">Slot online</a></li><li><a href="https://www.oxfordancestors.com/">Judi online</a></li><li><a href="https://www.goal55.id/" rel="noopener" target="_blank">Slot online</a></li><li><a href="https://casinoscout.ca/" rel="noopener" target="_blank">CasinoScout.ca</a></li><li><a href="https://betsquare.com/en-au/" title="Expires April 28, 2023">Betsquare.com</a></li><li><a href="https://www.casinosenpai.com">CasinoSenpai.com</a></li><li><a href="https://onlinecasinosspelen.com/" rel="noopener" target="_blank">OnlineCasinosSpelen</a></li></ul></aside><aside id="text-3" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside><aside id="text-2" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside></div></div></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="container"><div class="row"><div class="footer-widget-area"><div class="col-md-4"><div class="left-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="pages-6" class="widget widget_pages"><h2 class="footer-widget-title">Learn More</h2><ul><li class="page_item page-item-2"><a href="https://www.themovieblog.com/about/">About</a></li><li class="page_item page-item-7922"><a href="https://www.themovieblog.com/contact/">Contact Us</a></li></ul></aside></div></div></div><div class="col-md-4"><div class="mid-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="search-4" class="widget widget_search"><h2 class="footer-widget-title">Find What You&#8217;re Looking For</h2><form role="search" method="get" class="search-form" action="https://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="col-md-4"><div class="right-footer"><div id="secondary" class="widget-area" role="complementary"></div></div></div></div></div></div><div class="footer-site-info"><div class="container"> <span class="sep"> | </span></div></div></footer></div><div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v13.0&appId=213014669302515&autoLogAppEvents=1"></script> <div id="fb-root"></div><script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7&appId=293076464454881";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <!-- <link rel='stylesheet' id='dashicons-css'  href='https://www.themovieblog.com/wp-includes/css/dashicons.min.css?ver=6.0.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/9k8gom7u/dctvs.css" media="all"/> <script type='text/javascript' id='disqus_embed-js-extra'>var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"973594 https:\/\/www.themovieblog.com\/?p=973594","disqusShortname":"therealmovieblog","disqusTitle":"Chicago: Strange World Advance Screening Giveaway","disqusUrl":"https:\/\/www.themovieblog.com\/2022\/11\/chicago-strange-world-advance-screening-giveaway\/","postId":"973594"};</script> <script type='text/javascript' id='wp-util-js-extra'>var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript' id='wp_review-js-js-extra'>var wpreview = {"ajaxurl":"https:\/\/www.themovieblog.com\/wp-admin\/admin-ajax.php","popup":{"enable":"0","width":"800px","animation_in":"bounceIn","animation_out":"bounceOut","overlay_color":"#0b0b0b","overlay_opacity":"0.8","post_type":"post","queryby":"category","orderby":"random","category":"0","tag":"0","review_type":"star","limit":"6","expiration":"30","cookie_name":"wpr-popup","delay":"0","show_on_load":false,"show_on_reach_bottom":false,"exit_intent":true,"screen_size_check":false,"screen_width":"0","embed_show_title":"","embed_show_thumbnail":"","embed_show_excerpt":"","embed_show_rating_box":"","embed_show_credit":""},"rateAllFeatures":"Please rate all features","verifiedPurchase":"(Verified purchase)","commentImageUploadNonce":"6c58b6e2d1"};</script> <script type='text/javascript' id='thickbox-js-extra'>var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.themovieblog.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};</script> <script defer src="https://www.themovieblog.com/wp-content/cache/autoptimize/js/autoptimize_8512ea6c62c1ce4eb22dbd2d000b4403.js"></script></body></html><!-- WP Fastest Cache file was created in 2.70526909828 seconds, on 21-11-22 14:48:04 -->