<!DOCTYPE html><html lang="en-US"
xmlns:og="http://opengraphprotocol.org/schema/"
xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="http://www.themovieblog.com/xmlrpc.php"><!-- <link type="text/css" media="all" href="http://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_e0babc26b093938fc01345166938dba6.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/jzv6t97p/fjvog.css" media="all"/><!-- <link type="text/css" media="screen" href="http://www.themovieblog.com/wp-content/cache/autoptimize/css/autoptimize_2baad7f35bbed7a951e82f6c7abca532.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/2p4j9mx0/4b7d5.css" media="screen"/><title>Eric Roberts Answers Questions About His New Amazon Film &quot;Lone Star Deception&quot; &amp; His Career | The Movie Blog</title><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Eric Roberts Answers Questions About His New Amazon Film &quot;Lone Star Deception&quot; &amp; His Career | The Movie Blog" /><meta property="og:description" content="Back in 1986, in an interview with Roger Ebert following his screen debut performance in “King of the Gypsies,”  his break-through role, Ebert wrote: “Right from the beginning, Eric Roberts has had about him the promise of eventual greatness.  The movie industry does not know how he will turn out, ... [Read More]" /><meta property="og:url" content="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" /><meta property="og:site_name" content="The Movie Blog" /><meta property="article:publisher" content="https://www.facebook.com/TheMovieBlogOnline/" /><meta property="article:tag" content="Anthony Ray Parker" /><meta property="article:tag" content="Eliza Roberts" /><meta property="article:tag" content="Eric Roberts" /><meta property="article:tag" content="Eric Roberts on life and his career" /><meta property="article:tag" content="Lone Star Deception" /><meta property="article:tag" content="Lone Star Deception on Amazon" /><meta property="article:section" content="Interviews" /><meta property="article:published_time" content="2020-04-02T13:51:17+00:00" /><meta property="og:image" content="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM.png" /><meta property="og:image:width" content="919" /><meta property="og:image:height" content="384" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Back in 1986, in an interview with Roger Ebert following his screen debut performance in “King of the Gypsies,”  his break-through role, Ebert wrote: “Right from the beginning, Eric Roberts has had about him the promise of eventual greatness.  The movie industry does not know how he will turn out, ... [Read More]" /><meta name="twitter:title" content="Eric Roberts Answers Questions About His New Amazon Film &quot;Lone Star Deception&quot; &amp; His Career | The Movie Blog" /><meta name="twitter:site" content="@tmb_tweets" /><meta name="twitter:image" content="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM.png" /><meta name="twitter:creator" content="@tmb_tweets" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.themovieblog.com/#organization","name":"The Movie Blog","url":"http://www.themovieblog.com/","sameAs":["https://www.facebook.com/TheMovieBlogOnline/","https://www.youtube.com/channel/UC_TTz3vTPWqSgrqGdW2LLlQ","https://twitter.com/tmb_tweets"],"logo":{"@type":"ImageObject","@id":"http://www.themovieblog.com/#logo","url":"http://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_.png","width":512,"height":512,"caption":"The Movie Blog"},"image":{"@id":"http://www.themovieblog.com/#logo"}},{"@type":"WebSite","@id":"http://www.themovieblog.com/#website","url":"http://www.themovieblog.com/","name":"The Movie Blog","description":"The Official Home of Correct Movie Opinions","publisher":{"@id":"http://www.themovieblog.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.themovieblog.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#primaryimage","url":"http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM.png","width":919,"height":384},{"@type":"WebPage","@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#webpage","url":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/","inLanguage":"en-US","name":"Eric Roberts Answers Questions About His New Amazon Film &quot;Lone Star Deception&quot; &amp; His Career | The Movie Blog","isPartOf":{"@id":"http://www.themovieblog.com/#website"},"primaryImageOfPage":{"@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#primaryimage"},"datePublished":"2020-04-02T13:51:17+00:00","dateModified":"2020-04-02T13:51:17+00:00"},{"@type":"Article","@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#article","isPartOf":{"@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#webpage"},"author":{"@id":"http://www.themovieblog.com/#/schema/person/dc2ac1b21eed4af4041d91abedd4f22d"},"headline":"Eric Roberts Answers Questions About His New Amazon Film &#8220;Lone Star Deception&#8221; &#038; His Career","datePublished":"2020-04-02T13:51:17+00:00","dateModified":"2020-04-02T13:51:17+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#webpage"},"publisher":{"@id":"http://www.themovieblog.com/#organization"},"image":{"@id":"http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#primaryimage"},"keywords":"Anthony Ray Parker,Eliza Roberts,Eric Roberts,Eric Roberts on life and his career,Lone Star Deception,Lone Star Deception on Amazon","articleSection":"Interviews"},{"@type":["Person"],"@id":"http://www.themovieblog.com/#/schema/person/dc2ac1b21eed4af4041d91abedd4f22d","name":"Connie Wilson","image":{"@type":"ImageObject","@id":"http://www.themovieblog.com/#authorlogo","url":"http://1.gravatar.com/avatar/d7943e8e6d5dd3d03d3fd3bfccf17c0d?s=96&d=mm&r=pg","caption":"Connie Wilson"},"description":"Connie (Corcoran) Wilson (www.ConnieCWilson.com ) was the Quad City Times film and book critic for 15 years and has continued reviewing film uninterruptedly since 1970. She also publishes books (31 at last count) in a variety of genres (www.quadcitieslearning.com), has taught writing or literature classes at 6 Iowa/Illinois colleges or universities as adjunct faculty, was Yahoo's Content Producer of the Year 2008 for Politics, is the author of It Came from the 70s: From The Godfather to Apocalypse Now, and writes on a variety of topics at her own blog, www.WeeklyWilson.com.","sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Feed" href="http://www.themovieblog.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Comments Feed" href="http://www.themovieblog.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Movie Blog &raquo; Eric Roberts Answers Questions About His New Amazon Film &#8220;Lone Star Deception&#8221; &#038; His Career Comments Feed" href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.themovieblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='awaken-pro-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu%3Aregular%2Citalic%2C700%2C500|Roboto+Condensed%3Aregular%2Citalic%2C700|Source+Sans+Pro%3Aregular%2Citalic%2C700%26subset%3Dlatin%2Clatin' type='text/css' media='screen' /> <script src='//www.themovieblog.com/wp-content/cache/wpfc-minified/2z58oyc3/4b7d5.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='http://www.themovieblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> --> <!--[if lt IE 9]> <script type='text/javascript' src='http://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/respond.min.js?ver=5.3.2'></script> <![endif]--> <!--[if lt IE 9]> <script type='text/javascript' src='http://www.themovieblog.com/wp-content/themes/awaken-pro.2.1.2/awaken-pro/js/html5shiv.js?ver=5.3.2'></script> <![endif]--><link rel='https://api.w.org/' href='http://www.themovieblog.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.themovieblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.themovieblog.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='http://www.themovieblog.com/?p=955041' /><link rel="alternate" type="application/json+oembed" href="http://www.themovieblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.themovieblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F&#038;format=xml" /><meta property="fb:app_id" content="213014669302515"/><meta property="og:locale" content="en_US" /><meta property="og:locale:alternate" content="en_US" /><meta property="fb:app_id" content="293076464454881" /><meta property="og:site_name" content="The Movie Blog" /><meta property="og:title" content="Eric Roberts Answers Questions About His New Amazon Film “Lone Star Deception” &amp; His Career" /><meta property="og:url" content="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" /><meta property="og:description" content="Back in 1986, in an interview with Roger Ebert following his screen debut performance in “King of the Gypsies,”  his break-through role, Ebert wrote: “Right from the beginning, Eric Roberts has had about him the promise of eventual greatness.  The movie industry does not know how he will turn out,&lt;a class=&quot;moretag&quot; href=&quot;http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/&quot;&gt; ... [Read More]&lt;/a&gt;" /><meta property="og:type" content="Article" /><link rel="icon" href="http://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-32x32.png" sizes="32x32" /><link rel="icon" href="http://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="http://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-180x180.png" /><meta name="msapplication-TileImage" content="http://www.themovieblog.com/wp-content/uploads/2017/03/cropped-tmb_new_logo-web.ICON_-270x270.png" /></head><body class="post-template-default single single-post postid-955041 single-format-standard group-blog "><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><div class="top-nav"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 "><nav id="top-navigation" class="top-navigation" role="navigation"><div class="menu-social-bot-container"><ul id="menu-social-bot" class="menu"><li id="menu-item-229448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229448"><a href="https://www.twitter.com/TMB_Tweets">Twitter</a></li><li id="menu-item-229449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229449"><a title="publisher" href="https://plus.google.com/109872712801302940080">Google +</a></li><li id="menu-item-229450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229450"><a href="https://www.facebook.com/pages/The-Movie-Blog-Fan-Page/336692746071">Facebook</a></li><li id="menu-item-229452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-229452"><a href="http://www.themovieblog.com/feed">RSS</a></li><li id="menu-item-947974" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-947974"><a href="https://www.instagram.com/themovieblogonline">Instagram</a></li></ul></div></nav> <a href="#" class="navbutton" id="top-nav-button">Top Menu</a><div class="responsive-topnav"></div></div><div class="col-xs-12 col-sm-12 col-md-4"><div class="asocial-area"> <span class="asocial-icon facebook"><a href="https://www.facebook.com/TheMovieBlogOnline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Facebook" target="_blank"><i class="fa fa-facebook"></i></a></span> <span class="asocial-icon twitter"><a href="https://twitter.com/tmb_tweets?lang=en" data-toggle="tooltip" data-placement="bottom" title="Find us on Twitter" target="_blank"><i class="fa fa-twitter"></i></a></span> <span class="asocial-icon youtube"><a href="https://www.youtube.com/c/Themovieblog?sub_confirmation=1" data-toggle="tooltip" data-placement="bottom" title="Find us on Youtube" target="_blank"><i class="fa fa-youtube"></i></a></span> <span class="asocial-icon rss"><a href="http://www.themovieblog.com/feed" data-toggle="tooltip" data-placement="bottom" title="Find us on RSS" target="_blank"><i class="fa fa-rss"></i></a></span> <span class="asocial-icon instagram"><a href="https://www.instagram.com/themovieblogonline/" data-toggle="tooltip" data-placement="bottom" title="Find us on Instagram" target="_blank"><i class="fa fa-instagram"></i></a></span></div></div></div></div></div><div class="site-branding"><div class="container"><div class="site-brand-container"><div class="site-title-text"><h1 class="site-title"><a href="http://www.themovieblog.com/" rel="home">The Movie Blog</a></h1><h2 class="site-description">The Official Home of Correct Movie Opinions</h2></div></div><div class="header-ad-area"><div id="secondary" class="widget-area" role="complementary"><aside id="text-12" class="widget widget_text"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-1282480773966371"
data-ad-slot="7135789799"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div></div></div></div><div class="container"><div class="awaken-navigation-container"><nav id="site-navigation" class="main-navigation cl-effect-10" role="navigation"><div class="menu-browse-container"><ul id="menu-browse" class="menu"><li id="menu-item-229439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-229439"><a href="http://www.themovieblog.com/category/uncategorized/">News Chat</a><ul class="sub-menu"><li id="menu-item-940556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940556"><a href="http://www.themovieblog.com/category/uncategorized/comics-chat/">Comics Chat</a></li><li id="menu-item-940557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940557"><a href="http://www.themovieblog.com/category/uncategorized/tv-chat/">TV Chat</a></li></ul></li><li id="menu-item-229440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229440"><a href="http://www.themovieblog.com/category/features/reviews/">Reviews</a></li><li id="menu-item-229441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229441"><a href="http://www.themovieblog.com/category/trailers/">Trailers</a></li><li id="menu-item-229442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-229442"><a href="http://www.themovieblog.com/category/posters/">Posters</a></li><li id="menu-item-229443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-229443"><a href="http://www.themovieblog.com/category/features/interviews/">Interviews</a></li><li id="menu-item-918311" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-918311"><a href="http://www.themovieblog.com/category/features/">Features</a></li><li id="menu-item-947973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-947973"><a href="http://www.themovieblog.com/category/features/contests/">Contests</a></li><li id="menu-item-931821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931821"><a href="http://www.themovieblog.com/contact/">Contact Us</a></li><li id="menu-item-931822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-931822"><a href="http://www.themovieblog.com/about/">About</a></li></ul></div></nav> <a href="#" class="navbutton" id="main-nav-button">Main Menu</a><div class="responsive-mainnav"></div><div class="awaken-search-button-icon"></div><div class="awaken-search-box-container"><div class="awaken-search-box"><form action="http://www.themovieblog.com/" id="awaken-search-form" method="get"> <input type="text" value="" name="s" id="s" /> <input type="submit" value="Search" /></form></div></div></div></div></header><div id="content" class="site-content"><div class="container"><div class="row"><div class="col-xs-12 col-sm-12 col-md-8 awaken-content-float"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><article id="post-955041" class="post-955041 post type-post status-publish format-standard has-post-thumbnail hentry category-interviews tag-anthony-ray-parker tag-eliza-roberts tag-eric-roberts tag-eric-roberts-on-life-and-his-career tag-lone-star-deception tag-lone-star-deception-on-amazon"><header class="single-entry-header"><h1 class="single-entry-title">Eric Roberts Answers Questions About His New Amazon Film &#8220;Lone Star Deception&#8221; &#038; His Career</h1><div class="single-entry-meta"> <span class="posted-on"><a href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-02T09:51:17-04:00">April 2, 2020</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="http://www.themovieblog.com/author/connie-wilson/">Connie Wilson</a></span></span> <span class="comments-link"><a href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="955041 http://www.themovieblog.com/?p=955041">Leave a comment</span></a></span></div></header><div class="article-featured-image"> <img width="752" height="384" src="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM-752x384.png" class="attachment-featured-slider size-featured-slider wp-post-image" alt="" /></div><div class="entry-content"><div class="fb-like" data-href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div><figure id="attachment_955047" aria-describedby="caption-attachment-955047" style="width: 291px" class="wp-caption alignleft"><img class="wp-image-955047 size-thumbnail" src="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.11.13-PM-291x161.png" alt="" width="291" height="161" /><figcaption id="caption-attachment-955047" class="wp-caption-text">&#8220;Lone Star Deception&#8221;</figcaption></figure><p>Back in 1986, in an interview with Roger Ebert following his screen debut performance in “King of the Gypsies,”  his break-through role, Ebert wrote: <strong>“Right from the beginning, Eric Roberts has had about him the promise of eventual greatness.  The movie industry does not know how he will turn out, but he holds the potential to be mentioned with Brando and DeNiro and the others who come surrounded with the aura of a special talent.”</strong></p><p>&nbsp;</p><p>I fully agree with Roger Ebert’s assessment of Eric Roberts’ talent. I echo Academy-Award winning actress Sandy Dennis, who said of Eric after they appeared together onstage, <strong>“Oh, my God, this actor! I think he is the next big thing<u>,&#8212; if he can get the material</u>.”</strong></p><p>Eric’s performance in “King of the Gypsies earned him a Golden Globe nomination for the <strong>Best Acting</strong> <strong>Debut by an Actor (1979).</strong> Eric would go on to earn another Golden Globe nomination in 1984 for “Star 80” and a third Golden Globe nomination, plus an Oscar nomination as Best Supporting Actor (in support of Jon Voight) for  “Runaway Train.” 1984 gave us “The Pope of Greenwich Village,” with Eric paired with Mickey Rourke. He was awarded the Theater World Award in 1987 for the Best Broadway debut for his work in “Burn This.” Eric has been quoted as saying, <strong>“The joy is in the doing.”</strong></p><p>Every one of these films is indicative of the power and creativity that Eric Roberts brings to his work. He has another 29 wins and 17 nominations for a variety of film awards. Eliza Roberts&#8212;herself an actress and Eric’s wife of 28 years&#8212;said of her husband’s work, <strong>“Sit tight, because, even when you’re shit, you’re fucking awesome, Eric.”</strong></p><p>Sometimes <strong>called “the hardest-working actor in America,”</strong> Eric now has an absolutely stunning <strong>569</strong> credits on the International Movie Data Base, making him the hardest-working actor in Hollywood.</p><p>&nbsp;</p><figure id="attachment_17755" aria-describedby="caption-attachment-17755" style="width: 300px" class="wp-caption alignleft"><img class="size-medium wp-image-17755" src="http://weeklywilson.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM-300x125.png" alt="" width="300" height="125" /><figcaption id="caption-attachment-17755" class="wp-caption-text"><strong>Eric Roberts &amp; Anthony Ray Parker</strong>.<span style="font-size: 16px;">Eric’s schedule, as Eliza will attest, is crazy. It sometimes has him moving between 3 sets at once. He has close to 70 projects in development in 2020 or 2021. To give you a sense of how absolutely amazing that number of credits is, (outside of Bollywood), Leonardo DiCaprio, who has only 55 IMDB credits to his name, has said of </span><strong style="font-size: 16px;">Eric </strong><strong style="font-size: 16px;">“Eric</strong> <strong style="font-size: 16px;">is a god. He’s THE MAN</strong><span style="font-size: 16px;">.” By comparison, Brad Pitt has 56. Susan Sarandon, who co-starred with Eric in 1978’s “King of the Gypsies”&#8212; and is known to work quite frequently, herself,&#8212; has 160 credits</span><strong style="font-size: 16px;">One of Eric’s most recent films, “Lone Star Deception” is the story of a race for Governor in Texas, with Anthony Ray Parker as a black candidate for Governor</strong><span style="font-size: 16px;">. Eric is central to the plot, playing Bill Sagle, a King-maker who was originally backing his nephew, until his nephew is compromised by a sex-tape that surfaces, complete with a demand for hush money. The nephew is forced (</span><em style="font-size: 16px;">by Eric’s Bill Sagle character)</em><span style="font-size: 16px;"> to step down and a black candidate with combat credentials is drafted to run in his place. The co-star is Anthony Ray Parker who appeared in both “The Matrix” and “The Marine” and has 54 IMDB credits to his name, himself. The log-line says, </span><strong style="font-size: 16px;">“Fear, Greed and Texas Politics,”</strong><span style="font-size: 16px;"> which seemed like a good topic right about now, nationwide.</span></figcaption></figure><p><img class="alignnone size-medium wp-image-955043" src="http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-594x891.jpg" alt="" width="594" height="891" srcset="http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-594x891.jpg 594w, http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-683x1024.jpg 683w, http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-768x1152.jpg 768w, http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-1024x1536.jpg 1024w, http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-1365x2048.jpg 1365w, http://www.themovieblog.com/wp-content/uploads/2020/03/LoneStarDeception_KeyArt-scaled.jpg 1707w" sizes="(max-width: 594px) 100vw, 594px" /></p><p>************</p><p><strong>ERIC/ELIZA ROBERTS Questions</strong></p><figure id="attachment_17734" aria-describedby="caption-attachment-17734" style="width: 225px" class="wp-caption alignleft"><img class="size-medium wp-image-17734" src="http://weeklywilson.com/wp-content/uploads/2020/03/LSDsnake-225x300.jpg" alt="" width="225" height="300" /><figcaption id="caption-attachment-17734" class="wp-caption-text"><strong>&#8220;Lone Star Deception&#8221; is available on Amazon) with Eric Roberts and Anthony Ray Parker.</strong></figcaption></figure><p><strong>1_ You have close to 70 projects scheduled for 2020/2021. How do you manage to  work in that many films at once?</strong></p><p style="padding-left: 40px;">E.R.:  IT&#8217;S ALL ABOUT CREATIVE AND PRECISE, YET FLEXIBLE SCHEDULING. YOU HAVE TO BELIEVE ANYTHING IS POSSIBLE.</p><p><strong>2) How difficult is it to memorize that much dialogue and remember it all, when you’re working with so many different films at once?</strong></p><p style="padding-left: 40px;">E.R.:  IT&#8217;S GREAT MENTAL EXERCISE, SO I APPROACH IT LIKE WORKING OUT.</p><p>3)       You were offered “9 and ½ Weeks” but turned it down<strong>. Are there any other roles you were offered, but ended up not taking? Did you ever wish you had taken those roles?</strong></p><p style="padding-left: 40px;">E.R.:  AN OFFICER AND A GENTLEMAN, AMERICAN GIGOLO…BASICALLY MOST OF WHAT RICHARD GERE AND JOHN TRAVOLTA DID IN THEIR EARLY YEARS.</p><p style="padding-left: 40px;">ALSO CLIFFHANGER, WHICH ENDED UP GOING TO JOHN LITHGOW. I HOPE I’VE MADE UP FOR UNFORTUNATE TURN-DOWNS NOW.</p><p><strong>4)      Eliza:  your father, I read, wrote the scripts for “Three Days of the Condor” and “The Firm” (David Rayfiel).  You also knew John Landis, who offered you your part of Brunella in “Animal House.” Did you grow up in Hollywood? If so, has your insider knowledge of the industry helped?</strong></p><p style="padding-left: 40px;">E.R.:  I DID SCHLOCK AND <em>ANIMAL HOUSE</em> WITH JOHN LANDIS, AND HE’S REMAINED A FRIEND ALWAYS. I THINK GROWING UP IN THE INDUSTRY AND HAVING AN INTIMATE KNOWLEDGE OF THIS WORLD HAS HELPED IMMENSELY.</p><figure id="attachment_955045" aria-describedby="caption-attachment-955045" style="width: 594px" class="wp-caption aligncenter"><img class="size-medium wp-image-955045" src="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.33-PM-594x251.png" alt="" width="594" height="251" srcset="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.33-PM-594x251.png 594w, http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.33-PM-768x324.png 768w, http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.33-PM.png 919w" sizes="(max-width: 594px) 100vw, 594px" /><figcaption id="caption-attachment-955045" class="wp-caption-text">&#8220;Lone Star Deception&#8221;</figcaption></figure><p><strong>5)      Eliza, you met Eric on a plane with your dad’s script for “Intersection” in your lap. Have there been any projects, past, present or future, where you’ve been involved in writing a script just for Eric ? (<em>Secondary mention of cats, since Eric, you said, had a cat, Tender, on his lap at the time).</em></strong></p><p style="padding-left: 40px;">E.R.:  YES, I HAD A SCRIPT ON MY LAP AND ERIC HAD BOTH A SCRIPT AND A CAT ON HIS LAP.</p><p style="padding-left: 40px;">I HAVE DONE A LOT OF SCRIPT POLISHING FOR ERIC. I HAD A SENSE OF WHAT WORKS FOR HIM, AND MOST PRODUCTIONS ARE OPEN TO IT.</p><p><strong>6)       Eric, How did you come to be involved in “Lone Star Deception?” <em>(I  talked to Executive Producer Ed DeZavellos on 3/12 and hope to again in the future.)</em></strong></p><p style="padding-left: 40px;">E.R.:  I CAN’T REMEMBER FULLY, BUT I KNOW SOME VERY NICE, PASSIONATE PEOPLE MADE US BOTH AN OFFER. ELIZA IS IN LONE STAR DECEPTION, TOO. WE WERE INTRIGUED AND SAID YES.</p><p><strong>7)  &#8220;iIn my estimation, Eric is a great actor&#8230;an extremely unique presence trapped in this beautiful exterior&#8230;The way that Mickey Rourke was re-discovered as a great actor, I think Eric is due for that, for sure.  So much of the business is luck and timing.&#8221; (David Duchovny)</strong></p><p style="padding-left: 40px;">Given those glowing words from a fellow actor, and Mickey Rourke’s film “The Wrestler” (<em>which should have won him the Oscar in 2008</em>), what directors now working would you like to work with? Any potential star vehicles in the pipeline?</p><p style="padding-left: 40px;">E.R.:  I VERY MUCH WISH AND LONG FOR SUCH A VEHICLE. HOW PRECIOUS THAT WOULD BE.</p><p style="padding-left: 40px;">I CAN’T TELL YOU HOW MUCH THE COMMENTS OF THESE FELLOW ACTORS MEAN.</p><p>8)_  <strong>Nowadays, it seems that even extremely good actors like Robert Downey, Jr., want to play a Super Hero to cash in on the Marvel Universe films or to have a series built around them. It is as though there is the series comic book Hollywood and  indie film Hollywood</strong>. <strong><u>You’ve watched the industry as an insider for a long time. What are your thoughts on the films you see coming out of Hollywood now, versus when you were starting out (1978)?</u></strong></p><p style="padding-left: 40px;">E.R. : TRENDS IN ART AND IN EVERYTHING, ARCHITECTURE, FASHION, EVERYTHING, TEND TO CHANGE. MOVIES MADE PEOPLE HAPPY IN 1978, AND THEY MAKE PEOPLE HAPPY TODAY.</p><p style="padding-left: 40px;">SOME OF THE MARVEL MOVIES ARE VERY CLEVERLY WRITTEN AND GO WAY BEYOND THEIR GENRE.</p><p style="padding-left: 40px;">I DON’T HAVE A PARTICULAR LOVE FOR THE SUPER HERO FILMS, BUT MANY PEOPLE DO, AND BECAUSE OF THAT, I’D LOVE TO BE A PART OF IT.</p><figure id="attachment_955047" aria-describedby="caption-attachment-955047" style="width: 594px" class="wp-caption aligncenter"><img class="size-medium wp-image-955047" src="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.11.13-PM-594x248.png" alt="" width="594" height="248" srcset="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.11.13-PM-594x248.png 594w, http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.11.13-PM-768x320.png 768w, http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.11.13-PM.png 919w" sizes="(max-width: 594px) 100vw, 594px" /><figcaption id="caption-attachment-955047" class="wp-caption-text">&#8220;Lone Star Deception&#8221;</figcaption></figure><p><strong>9)  </strong><strong>Throwing out some names that I know mean something to you, can you share with us a little bit about what it was like working with Sterling Hayden…..Mickey Rourke…..Jon Voight…Bob Fosse…and, of course, Anthony Ray Parker. (Take your pick and add any others you wish).</strong></p><p style="padding-left: 40px;">I LEARNED SO MUCH FROM STERLING. WHAT A CHARACTER! I ADORE MICKEY, AND HE AMAZES ME. IT WAS FANTASTIC WORKING WITH JON. BOB FOSSEE WAS ARGUABLY THE BEST DIRECTOR I WAS EVER DIRECTED BY. WE HAD AN INCREDIBLE TIME WORKING WITH ANTHONY RAY PARKER. HE&#8217;S A GREAT ACTOR AND HE&#8217;S A GREAT MAN.</p><p><strong style="font-size: 16px;">10)  </strong><strong style="font-size: 16px;">“Lone Star Deception” Credits: “We would like to thank our pyro technicians for not blowing up the entire city. (Houston) [Comments?]</strong></p><p style="padding-left: 40px;">HILARIOUS! AND TRUE.</p><p><strong>11)  </strong><strong>You were in a bad car accident in 1981. Please tell us about that and its after-effects at the time?</strong></p><p style="padding-left: 40px;">E.R.:  WELL, IT WAS A LOT LIKE THE FILM “REGARDING HENRY”.</p><p style="padding-left: 40px;">I CRASHED IN MY JEEP AND WAS IN A COMA FOR 72 HOURS AND, EVEN THOUGH I WAS PHYSICALLY ALIVE, IT MADE ME FEEL FOREVER DIFFERENT IN MYRIAD WAYS.</p><p><strong>12)  </strong><strong>Don Okolo, the credited director for “Lone Star Deception” is Don Okolo. (“Blood ‘n Destiny” – 2009, $500,000; “The Land” – 2011, $200,000; “Gem of the Rainforest” – 2013 &#8211; $200,000).  Have you ever wanted to direct?</strong></p><p style="padding-left: 40px;">ELIZA IS A SUPER GIFTED DIRECTOR AND I LOVE BEING DIRECTED BY HER AND WOULD CO-DIRECT WITH HER.</p><p><strong>13)  </strong><strong>Lines from the film: “So little nieces, so little time.” “Politicians tell the voters what they want to hear.” Why was the main character (<em>Tim Bayh, the black candidate for Governor</em>) put in charge of personally paying off the various wrongdoers, such as those who kidnap his daughter Carol. Aren’t there less visible henchmen who could have been hired to carry the $50,000 to pay off “Sloane?” (<em>That puzzled me)</em><br /> </strong></p><p style="padding-left: 40px;">E.R.:  TIM HAD MORE AT STAKE. BUT THAT’S A GOOD QUESTION AND REALLY A QUESTION FOR ED.</p><p><strong> 14) It was always about the money, Charlie.” (</strong><strong>Any thoughts on the politics of today IRL?)</strong></p><p style="padding-left: 40px;">E.R.: It SEEMS&lt; WHen you BOIL It DOWN, EVERYTHING IS ABOUT THE MONEY.</p><p><strong>15.  &#8220;I&#8217;ll be taking a break when I die.&#8221;</strong></p><p style="padding-left: 40px;">E.R.;  YES, SOUNDS LIKE ME!</p><p><strong>16)  </strong><strong>“The hardest person to protect yourself from is yourself.”</strong></p><p style="padding-left: 40px;">E.R.:  I BELIEVE THAT.</p><p><strong>17)  </strong><strong>Daughter, Emma; Morgan and Keaton (musician). Currently working in the industry, or…? </strong></p><p style="padding-left: 40px;">E.R.:  ALL IN THE INDUSTRY.</p><p><strong>18)  </strong><strong>“Why me, of all the guys, of all the has-beens, of all the good actors who are over&#8212;why me?” (1/31/2018 to Sam Kashner for <em>Vanity Fair.)</em></strong></p><p style="padding-left: 40px;">E.R.:  WHY ME? IS NOT A RHETORICAL QUESTION. IT’S ABOUT UNDERSTANDING OUR PART IN OUR LIVES. THE MOST IMPORTANT PART WE PLAY.</p><p><strong>19)  </strong><strong> Your favorite Batman?</strong></p><p style="padding-left: 40px;">E.R.:  MICHAEL KEATON.</p><p><strong>20)  </strong><strong>Your favorite Joker actor in the &#8220;Batman&#8221; films?</strong></p><p style="padding-left: 40px;">E.R.:  JACK NICHOLSON</p><p><strong>21)  </strong><strong>Anything you’d like to talk about that I haven&#8217;t asked you about?</strong></p><p style="padding-left: 40px;">YOU ASKED GREAT QUESTIONS.</p><p style="padding-left: 40px;">WE ALWAYS LIKE TO DIRECT LISTENERS/READERS TO</p><p style="padding-left: 40px;"><a href="http://WWW.NATURALCHILD.ORG" data-saferedirecturl="https://www.google.com/url?q=http://WWW.NATURALCHILD.ORG&amp;source=gmail&amp;ust=1584564936988000&amp;usg=AFQjCNGC3ZWWR5sr5KJJyixGWHZtzO1SIA">WWW.NATURALCHILD.ORG</a></p><p style="padding-left: 40px;">AND TO KEATON SIMONS</p><p style="padding-left: 40px;">AND TO <a href="http://WWW.PIBAKESHOP.COM" data-saferedirecturl="https://www.google.com/url?q=http://WWW.PIBAKESHOP.COM&amp;source=gmail&amp;ust=1584564936988000&amp;usg=AFQjCNEQwYIhbkUWJ3XQ-G1Xe-mNc3J39A">WWW.PIBAKESHOP.COM</a></p><div id="wpdevar_comment_4" style="width:100%;text-align:left;"> <span style="padding: 10px;font-size:18px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#1e73be;">Comment with Facebook</span><div class="fb-comments" data-href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" data-order-by="social" data-numposts="10" data-width="100%" style="display:block;"></div></div><div class="fb-like" data-href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/" data-layout="standard" data-action="like" data-show-faces="false" data-size="small" data-width="450" data-share="1" ></div><div id="review" class="review-wrapper wp-review-955041 wp-review-point-type wp-review-default-template wp-review-box-full-width"><div class="user-review-area visitors-review-area"><div class="wp-review-user-rating wp-review-user-rating-point"><div class="wp-review-rating-input review-point"><div class="wp-review-loading-msg"> <span class="animate-spin fa fa-spinner"></span> Sending</div><div class="review-result-wrapper" data-originalrating="0.0" style="background-color: #95bae0;"><div class="review-result" style="width:0%; background-color: #1e73be; display: block; transition: none;"></div></div><div class="wp-review-your-rating" style="background-color: #1e73be; color: #95bae0;"> <span class="wp-review-your-rating-value"></span></div> <input type="hidden" class="wp-review-user-rating-val" name="wp-review-user-rating-val" value="0.0" /> <input type="hidden" class="wp-review-user-rating-nonce" value="67cdcfbc1d" /> <input type="hidden" class="wp-review-user-rating-postid" value="955041" /></div></div><div class="user-total-wrapper"><h5 class="user-review-title">User Review</h5> <span class="review-total-box"> <span class="wp-review-user-rating-total">0/10</span> <small>(<span class="wp-review-user-rating-counter">0</span> votes)</small> </span></div></div></div> <script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "Review",
"itemReviewed": {
"@type": "Thing",
"name": "Eric Roberts Answers Questions About His New Amazon Film &#8220;Lone Star Deception&#8221; &#038; His Career"
},
"reviewRating": {
"@type": "Rating",
"ratingValue": "0",
"bestRating": 10
},
"author": {
"@type": "Person",
"name": "Connie Wilson"
},
"reviewBody": ""
}</script> </div><footer class="single-entry-footer"> <span class="categorized-under">Posted Under</span><div class="awaken-category-list"><a href="http://www.themovieblog.com/category/features/interviews/" rel="category tag">Interviews</a></div><div class="clearfix"></div><span class="tagged-under">Tagged</span><div class="awaken-tag-list"><a href="http://www.themovieblog.com/tag/anthony-ray-parker/" rel="tag">Anthony Ray Parker</a> <a href="http://www.themovieblog.com/tag/eliza-roberts/" rel="tag">Eliza Roberts</a> <a href="http://www.themovieblog.com/tag/eric-roberts/" rel="tag">Eric Roberts</a> <a href="http://www.themovieblog.com/tag/eric-roberts-on-life-and-his-career/" rel="tag">Eric Roberts on life and his career</a> <a href="http://www.themovieblog.com/tag/lone-star-deception/" rel="tag">Lone Star Deception</a> <a href="http://www.themovieblog.com/tag/lone-star-deception-on-amazon/" rel="tag">Lone Star Deception on Amazon</a></div><div class="clearfix"></div><div class="awp-shareicons"><div class="awp-shareicon-set"><a class="social-link awp-facebook" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F" target="_blank"><i class="fa fa-facebook"></i><span class="ss-text">Share on facebook</span></a><a class="social-link awp-twitter" href="https://twitter.com/intent/tweet?text=Eric%20Roberts%20Answers%20Questions%20About%20His%20New%20Amazon%20Film%20&#8220;Lone%20Star%20Deception&#8221;%20&#038;%20His%20Career&amp;url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F" target="_blank"><i class="fa fa-twitter"></i><span class="ss-text">Tweet on twitter</span></a><a class="social-link awp-googleplus" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F" target="_blank"><i class="fa fa-google-plus"></i></a><a class="social-link awp-whatsapp" href="whatsapp://send?text=Eric%20Roberts%20Answers%20Questions%20About%20His%20New%20Amazon%20Film%20&#8220;Lone%20Star%20Deception&#8221;%20&#038;%20His%20Career http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F" target="_blank"><i class="fa fa-instagram"></i></a><a class="social-link awp-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F&amp;title=Eric%20Roberts%20Answers%20Questions%20About%20His%20New%20Amazon%20Film%20&#8220;Lone%20Star%20Deception&#8221;%20&#038;%20His%20Career" target="_blank"><i class="fa fa-linkedin"></i></a><a class="social-link awp-pinterest" href="https://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.themovieblog.com%2F2020%2F04%2Feric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career%2F&amp;media=http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM.png&amp;description=Eric%20Roberts%20Answers%20Questions%20About%20His%20New%20Amazon%20Film%20&#8220;Lone%20Star%20Deception&#8221;%20&#038;%20His%20Career" target="_blank"><i class="fa fa-pinterest"></i></a></div></div></footer></article><div class="media profile"> <img alt='' src="https://1.gravatar.com/avatar/d7943e8e6d5dd3d03d3fd3bfccf17c0d?s=70&#038;d=mm&#038;r=pg" srcset='http://1.gravatar.com/avatar/d7943e8e6d5dd3d03d3fd3bfccf17c0d?s=140&#038;d=mm&#038;r=pg 2x' class='avatar avatar-70 photo' height='70' width='70' /><div class="bd"><h4>About Connie Wilson</h4><p>Connie (Corcoran) Wilson (www.ConnieCWilson.com ) was the Quad City Times film and book critic for 15 years and has continued reviewing film uninterruptedly since 1970. She also publishes books (31 at last count) in a variety of genres (www.quadcitieslearning.com), has taught writing or literature classes at 6 Iowa/Illinois colleges or universities as adjunct faculty, was Yahoo's Content Producer of the Year 2008 for Politics, is the author of It Came from the 70s: From The Godfather to Apocalypse Now, and writes on a variety of topics at her own blog, www.WeeklyWilson.com.</p><div class="profile-links"><ul class="social-links"></ul> <a class="authorlla" href="http://www.themovieblog.com/author/connie-wilson/"> View all posts by Connie Wilson <span class="meta-nav">&rarr;</span> </a></div></div></div><nav class="navigation post-navigation" role="navigation"><h1 class="screen-reader-text">Post navigation</h1><div class="nav-links"><div class="nav-previous"><a href="http://www.themovieblog.com/2020/04/interview-tichinca-arnold-netflix-the-main-event/" rel="prev">Interview: Tichinca Arnold Chats About The Netflix Film &#8220;The Main Event&#8221;</a></div></div></nav><div class="related-posts clearfix"><h2>You may like these posts</h2><div class="awaken-related-posts"><article class="rpost clearfix"><div class="amsr-thumb"> <a href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/"><img width="120" height="85" src="http://www.themovieblog.com/wp-content/uploads/2020/03/Screen-Shot-2020-02-10-at-12.13.08-PM-120x85.png" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="http://www.themovieblog.com/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/">Eric Roberts Answers Questions About His New Amazon Film &#8220;Lone Star Deception&#8221; &#038; His Career</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="http://www.themovieblog.com/2020/04/interview-tichinca-arnold-netflix-the-main-event/"><img width="120" height="85" src="http://www.themovieblog.com/wp-content/uploads/2020/04/Tichina-Arnold-Interview.Movie_Snapshot-e1585770719434-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="http://www.themovieblog.com/2020/04/interview-tichinca-arnold-netflix-the-main-event/">Interview: Tichinca Arnold Chats About The Netflix Film &#8220;The Main Event&#8221;</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="http://www.themovieblog.com/2020/03/tapestry-weaving-a-message-of-inspiration/"><img width="120" height="85" src="http://www.themovieblog.com/wp-content/uploads/2020/03/untitled-120x85.png" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="http://www.themovieblog.com/2020/03/tapestry-weaving-a-message-of-inspiration/">&#8220;Tapestry&#8221;: Weaving a Message of Inspiration</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="http://www.themovieblog.com/2020/03/i-daresay-nearly-all-of-us-have-been-the-guy-and-or-the-gal-in-this-story/"><img width="120" height="85" src="http://www.themovieblog.com/wp-content/uploads/2020/03/thumbnail_FOGGY20DAYS20OFFICIAL20POSTER202018201-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="http://www.themovieblog.com/2020/03/i-daresay-nearly-all-of-us-have-been-the-guy-and-or-the-gal-in-this-story/">&#8220;Foggy Days&#8221; makes it clear: Something worthwhile is happening in Swedish Short Film</a></h3></div></article><article class="rpost clearfix"><div class="amsr-thumb"> <a href="http://www.themovieblog.com/2020/02/blood-on-her-name-along-with-a-long-lineage-of-others/"><img width="120" height="85" src="http://www.themovieblog.com/wp-content/uploads/2020/02/BOHN-120x85.jpg" class="attachment-small-thumb size-small-thumb wp-post-image" alt="" /></a></div><div id="related-posts-title"><h3><a href="http://www.themovieblog.com/2020/02/blood-on-her-name-along-with-a-long-lineage-of-others/">&#8220;Blood on Her Name&#8221;: Along with a Long Lineage of Others</a></h3></div></article></div></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/04/eric-roberts-answers-questions-about-his-new-amazon-film-lone-star-deception-his-career/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.themovieblog.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='955041' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1c411c5a9b" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="59"/></p></form></div></div></main></div></div><div class="col-xs-12 col-sm-6 col-md-4 awaken-widgets-float"><div id="secondary" class="main-widget-area" role="complementary"><aside id="text-2" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside><aside id="awaken_pro_video_widget-2" class="widget widget_awaken_pro_video_widget"><div class="widget-title-container"><h2 class="widget-title">TMB on YouTube</h2></div><div class="awaken-video-widget video-container"> <iframe width="100%" height="100%" src="https://www.youtube.com/embed/BomXL8_WFdM" frameborder="0" allowfullscreen></iframe></div></aside><aside id="search-6" class="widget widget_search"><div class="widget-title-container"><h2 class="widget-title">Search The Movie Blog</h2></div><form role="search" method="get" class="search-form" action="http://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside><aside id="text-3" class="widget widget_text"><div class="widget-title-container"><h2 class="widget-title">A Few Words from our Sponsors</h2></div><div class="textwidget"><center> <script type="text/javascript">google_ad_client = "pub-1282480773966371";
/* 300x250, created 8/1/11 */
google_ad_slot = "5176104761";
google_ad_width = 300;
google_ad_height = 250;</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </center></div></aside><aside id="facebook-like-widget-4" class="widget widget_facebook-like-widget"><div class="widget-title-container"><h2 class="widget-title">Find us on Facebook</h2></div> <iframe src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FTheMovieBlogOnline%2F&amp;width=360&amp;colorscheme=light&amp;show_faces=true&amp;stream=true&amp;header=false&amp;height=600" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:360px; height: 600px; background: #FFF;"></iframe></aside><aside id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-title-container"><h2 class="widget-title">Reader Comments</h2></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://it.eco-designfinca.com/' rel='external nofollow ugc' class='url'>Ida Jonsson</a></span> on <a href="http://www.themovieblog.com/2008/06/the-real-reason-bill-murray-didnt-do-charlies-angels-2/#comment-365090">The Real Reason Bill Murray Didn&#8217;t Do Charlie&#8217;s Angels 2</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.themovieblog.com' rel='external nofollow ugc' class='url'>Anthony Whyte</a></span> on <a href="http://www.themovieblog.com/2020/02/theres-a-monster-hunter-movie-coming/#comment-364900">There&#8217;s a Monster Hunter movie coming?</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://Sbobetting.net' rel='external nofollow ugc' class='url'>Taruhan slot game</a></span> on <a href="http://www.themovieblog.com/2020/02/best-upcoming-slot-game-releases-to-look-out-for/#comment-364804">Best Upcoming Slot Game Releases To Look Out For</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://thedevicesupport.org/how-do-i-fix-spectrum-internet-not-working-with-wi-fi-router/' rel='external nofollow ugc' class='url'>Steve Jones</a></span> on <a href="http://www.themovieblog.com/2020/02/best-sci-fi-movies-available-with-spectrum-on-demand/#comment-364607">Best Sci-Fi Movies Available With Spectrum On-Demand</a></li><li class="recentcomments"><span class="comment-author-link">joshdani</span> on <a href="http://www.themovieblog.com/2020/03/7-great-birthday-gifts-for-movie-buffs/#comment-364432">7 Great Birthday Gifts for Movie Buffs</a></li></ul></aside><aside id="linkcat-2" class="widget widget_links"><div class="widget-title-container"><h2 class="widget-title">Blogroll</h2></div><ul class='xoxo blogroll'><li><a href="http://moviesblog.mtv.com/" target="_blank">MTV Movies Blog</a></li><li><a href="http://www.firstshowing.net" target="_blank">First Showing</a></li><li><a href="https://www.slashfilm.com" target="_blank">/Film</a></li><li><a href="http://www.screenrant.com" target="_blank">Screenrant</a></li><li><a href="http://www.filmschoolrejects.com" target="_blank">FilmSchoolRejects</a></li><li><a href="http://www.filmfad.com/" rel="acquaintance colleague" title="Film Fad &#8211; Ryan Brown" target="_blank">Film Fad</a></li><li><a href="http://www.WeeklyWilson.com">Weekly Wilson</a></li></ul></aside></div></div></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="container"><div class="row"><div class="footer-widget-area"><div class="col-md-4"><div class="left-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="pages-6" class="widget widget_pages"><h2 class="footer-widget-title">Learn More</h2><ul><li class="page_item page-item-2"><a href="http://www.themovieblog.com/about/">About</a></li><li class="page_item page-item-7922"><a href="http://www.themovieblog.com/contact/">Contact Us</a></li></ul></aside></div></div></div><div class="col-md-4"><div class="mid-footer"><div id="secondary" class="widget-area" role="complementary"><aside id="search-4" class="widget widget_search"><h2 class="footer-widget-title">Find What You&#8217;re Looking For</h2><form role="search" method="get" class="search-form" action="http://www.themovieblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="col-md-4"><div class="right-footer"><div id="secondary" class="widget-area" role="complementary"></div></div></div></div></div></div><div class="footer-site-info"><div class="container"> <span class="sep"> | </span></div></div></footer></div><div id="fb-root"></div> <script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=213014669302515&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <div id="fb-root"></div><script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7&appId=293076464454881";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <!-- <link rel='stylesheet' id='dashicons-css'  href='http://www.themovieblog.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.themovieblog.com/wp-content/cache/wpfc-minified/79w1vk31/4b7d5.css" media="all"/> <script type='text/javascript'>var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};</script> <script type='text/javascript'>var wpreview = {"ajaxurl":"http:\/\/www.themovieblog.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript'>var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.themovieblog.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};</script> <script type="text/javascript" defer src="http://www.themovieblog.com/wp-content/cache/autoptimize/js/autoptimize_13ef8a56ae1ea7485d870626eda66357.js"></script></body></html><!-- WP Fastest Cache file was created in 0.417213916779 seconds, on 02-04-20 9:51:20 -->